{"answers":{"affected":"1 open source package ship an affected version, including fluent-bit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-4323 in the wild and no public exploit code.","fix":"Upgrade fluent-bit to 3.0.4 or later.","what":"CVE-2024-4323 is a critical memory corruption vulnerability in Fluent Bit, published on 20 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4323 and fix it if it is affected.\n\nWhat it is: CVE-2024-4323 is a critical memory corruption vulnerability in Fluent Bit, published on 20 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-4323 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluent-bit (Bitnami): affected from 2.0.7; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4323/ (Markdown: https://insights.sbomify.com/CVE-2024-4323/index.md)","id":"CVE-2024-4323","markdown":"https://insights.sbomify.com/CVE-2024-4323/index.md","name":"CVE-2024-4323","record":{"aliases":["AZL-42103","AZL-42162","BIT-fluent-bit-2024-4323","GHSA-68mr-468g-4wmg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluent Bit log processor","requires_auth":"none","summary":"Attackers can exploit memory corruption in Fluent Bit's HTTP server to achieve remote code execution, denial of service, or information disclosure.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"tenable","cpe":[{"product":"fluent_bit","vendor":"treasuredata"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"A memory corruption vulnerability in Fluent Bit versions 2.0.7 thru 3.0.3. This issue lies in the embedded http server’s parsing of trace requests and may result in denial of service conditions, information disclosure, or remote code execution.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2024-05-20","github_poc":3,"max_poc_stars":15,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-05-20T15:04:13Z","kind":"github_poc","ref":"https://github.com/skilfoy/CVE-2024-4323-Exploit-POC","stars":15,"title":"This proof-of-concept script demonstrates how to exploit CVE-2024-4323, a memory corruption vulnerability in Fluent Bit, enabling remote code execution."},{"date":"2024-05-21T12:59:16Z","kind":"github_poc","ref":"https://github.com/d0rb/CVE-2024-4323","stars":1,"title":"Critical heap buffer overflow vulnerability in the handle_trace_request and parse_trace_request functions of the Fluent Bit HTTP server."},{"date":"2024-05-22T09:55:30Z","kind":"github_poc","ref":"https://github.com/yuansec/CVE-2024-4323-dos_poc","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Fluent Bit Memory Corruption Vulnerability","id":"CVE-2024-4323","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"WP Video Lightbox \u003c= 1.9.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via width Parameter","id":"CVE-2024-4324"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.4"],"introduced":["2.0.7"],"last_affected":[],"package":"fluent-bit","purl":"pkg:bitnami/fluent-bit","source":"BIT-fluent-bit-2024-4323"}],"prev":{"headline":"Path Traversal in parisneo/lollms-webui","id":"CVE-2024-4322"},"products":["Fluent Bit"],"published":"2024-05-20","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2021-36088","kev_date_added":null,"published":"2021-07-01"},{"cvss_score":9.1,"headline":"CVE-2025-12977","id":"CVE-2025-12977","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":8.8,"headline":"CVE-2025-12970","id":"CVE-2025-12970","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2021-46878","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2021-46879","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2020-35963","kev_date_added":null,"published":"2021-01-03"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-19","vendors":["Fluent Bit"]},"summary":"Attackers can exploit memory corruption in Fluent Bit's HTTP server to achieve remote code execution, denial of service, or information disclosure.","url":"https://insights.sbomify.com/CVE-2024-4323/"}