# CVE-2024-4323: Fluent Bit Memory Corruption Vulnerability

> Attackers can exploit memory corruption in Fluent Bit's HTTP server to achieve remote code execution, denial of service, or information disclosure.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2024
- **Updated:** 19 Aug 2024
- **Also known as:** AZL-42103, AZL-42162, BIT-fluent-bit-2024-4323, GHSA-68mr-468g-4wmg

## What is CVE-2024-4323?

CVE-2024-4323 is a critical memory corruption vulnerability in Fluent Bit, published on 20 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A memory corruption vulnerability in Fluent Bit versions 2.0.7 thru 3.0.3. This issue lies in the embedded http server’s parsing of trace requests and may result in denial of service conditions, information disclosure, or remote code execution.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-4323?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 2.0.7 | 3.0.4 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2024-4323?

Upgrade fluent-bit to 3.0.4 or later.

## Is CVE-2024-4323 being exploited?

There is no known exploitation of CVE-2024-4323 in the wild and no public exploit code.

Public exploit code:

- This proof-of-concept script demonstrates how to exploit CVE-2024-4323, a memory corruption vulnerability in Fluent Bit, enabling remote code execution. (github_poc): https://github.com/skilfoy/CVE-2024-4323-Exploit-POC
- Critical heap buffer overflow vulnerability in the handle_trace_request and parse_trace_request functions of the Fluent Bit HTTP server. (github_poc): https://github.com/d0rb/CVE-2024-4323
- https://github.com/yuansec/CVE-2024-4323-dos_poc (github_poc): https://github.com/yuansec/CVE-2024-4323-dos_poc

## Other vulnerabilities in Fluent Bit

- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)
- [CVE-2021-46879](https://insights.sbomify.com/CVE-2021-46879/): Memory corruption in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4323 and fix it if it is affected.

What it is: CVE-2024-4323 is a critical memory corruption vulnerability in Fluent Bit, published on 20 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4323 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 2.0.7; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4323/ (Markdown: https://insights.sbomify.com/CVE-2024-4323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4323
- OSV: https://osv.dev/vulnerability/CVE-2024-4323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4323/
Summaries are generated and may contain mistakes; the official description above is the record.
