{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4327 exists.","fix":"No fix has been published for CVE-2024-4327 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-4327 is a low-severity vulnerability in Apryse WebViewer, published on 30 Apr 2024."},"fix_prompt":"Check this codebase for CVE-2024-4327 and fix it if it is affected.\n\nWhat it is: CVE-2024-4327 is a low-severity vulnerability in Apryse WebViewer, published on 30 Apr 2024. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4327 exists.\n\nAffected product: Apryse WebViewer. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4327/ (Markdown: https://insights.sbomify.com/CVE-2024-4327/index.md)","id":"CVE-2024-4327","markdown":"https://insights.sbomify.com/CVE-2024-4327/index.md","name":"CVE-2024-4327","record":{"aliases":["GHSA-g666-fcvg-24h3"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Apryse WebViewer up to 10.8.0. It has been classified as problematic. This affects an unknown part of the component PDF Document Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.9 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-262419. NOTE: The vendor was contacted early about this disclosure and explains that the documentation recommends a strict Content Security Policy and the issue was fixed in release 10.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Apryse WebViewer PDF Document cross site scripting","id":"CVE-2024-4327","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2024"},"n_packages":0,"n_references":5,"next":{"headline":"CSRF in clear_personality_files_list in parisneo/lollms-webui","id":"CVE-2024-4328"},"packages":[],"prev":{"headline":"Remote Code Execution via `/apply_settings` and `/execute_code` in parisneo/lollms-webui","id":"CVE-2024-4326"},"products":["WebViewer"],"published":"2024-04-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-15","vendors":["Apryse"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-4327/"}