# CVE-2024-4327: Apryse WebViewer PDF Document cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 30 Apr 2024
- **Updated:** 15 Aug 2024
- **Also known as:** GHSA-g666-fcvg-24h3

## What is CVE-2024-4327?

CVE-2024-4327 is a low-severity vulnerability in Apryse WebViewer, published on 30 Apr 2024. 

### Official description

A vulnerability was found in Apryse WebViewer up to 10.8.0. It has been classified as problematic. This affects an unknown part of the component PDF Document Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.9 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-262419. NOTE: The vendor was contacted early about this disclosure and explains that the documentation recommends a strict Content Security Policy and the issue was fixed in release 10.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-4327?


## How do I fix CVE-2024-4327?

No fix has been published for CVE-2024-4327 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-4327 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4327 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4327 and fix it if it is affected.

What it is: CVE-2024-4327 is a low-severity vulnerability in Apryse WebViewer, published on 30 Apr 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4327 exists.

Affected product: Apryse WebViewer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4327/ (Markdown: https://insights.sbomify.com/CVE-2024-4327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4327
- OSV: https://osv.dev/vulnerability/CVE-2024-4327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4327/
Summaries are generated and may contain mistakes; the official description above is the record.
