{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-43337 in the wild and no public exploit code.","fix":"Upgrade wordpress to 0.7.1 or later.","what":"CVE-2024-43337 is a medium-severity vulnerability in Brave Popup Builder, published on 26 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-43337 and fix it if it is affected.\n\nWhat it is: CVE-2024-43337 is a medium-severity vulnerability in Brave Popup Builder, published on 26 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-43337 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 0.7.1\n- wordpress-multisite (Bitnami): affected all versions; fixed in 0.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43337/ (Markdown: https://insights.sbomify.com/CVE-2024-43337/index.md)","id":"CVE-2024-43337","markdown":"https://insights.sbomify.com/CVE-2024-43337/index.md","name":"CVE-2024-43337","record":{"aliases":["BIT-wordpress-2024-43337","BIT-wordpress-multisite-2024-43337","GHSA-4638-h2rx-8qf2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can trick authenticated users into performing unwanted actions in the Brave Popup Builder WordPress plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[{"product":"brave","vendor":"getbrave"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in Brave Brave Popup Builder.This issue affects Brave Popup Builder: from n/a through 0.7.0.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Brave plugin \u003c= 0.7.0 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-43337","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress Crowdsignal Polls \u0026 Ratings plugin \u003c= 3.1.3 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-43338"},"packages":[{"ecosystem":"Bitnami","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-43337"},{"ecosystem":"Bitnami","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-43337"}],"prev":{"headline":"Cross-site request forgery in WP User Manager","id":"CVE-2024-43336"},"products":["Brave Popup Builder"],"published":"2024-08-26","related":[{"cvss_score":5.9,"headline":"WordPress Brave – Interactive Content plugin \u003c= 0.6.9 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-35655","kev_date_added":null,"published":"2024-06-04"},{"cvss_score":5.9,"headline":"WordPress Brave Popup Builder Plugin \u003c= 0.6.2 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-51534","kev_date_added":null,"published":"2024-02-01"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Brave"]},"summary":"Attackers can trick authenticated users into performing unwanted actions in the Brave Popup Builder WordPress plugin.","url":"https://insights.sbomify.com/CVE-2024-43337/"}