# CVE-2024-43366: zkvyper ignored loop range bounds

> A flaw in the zkvyper compiler could cause incorrect loop execution, potentially leading to loss of funds in smart contracts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Aug 2024
- **Updated:** 16 Aug 2024
- **Also known as:** GHSA-8j77-7rrv-6pxx

## What is CVE-2024-43366?

CVE-2024-43366 is a high-severity vulnerability in matter-labs era-compiler-vyper, published on 15 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

zkvyper is a Vyper compiler. Starting in version 1.3.12 and prior to version 1.5.3, since LLL IR has no Turing-incompletness restrictions, it is compiled to a loop with a much more late exit condition. It leads to a loss of funds or other unwanted behavior if the loop body contains it. However, more real-life use cases like iterating over an array are not affected. No contracts were affected by this issue, which was fixed in version 1.5.3. Upgrading and redeploying affected contracts is the only way to avoid the vulnerability.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-43366?

It affects 1 product.


Products: Matter-Labs Zkvyper.

## How do I fix CVE-2024-43366?

No fix has been published for CVE-2024-43366 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-43366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43366 exists.

## Other vulnerabilities in matter-labs era-compiler-vyper

- [CVE-2023-46232](https://insights.sbomify.com/CVE-2023-46232/): era-compiler-vyper First Immutable Variable Initialization vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43366 and fix it if it is affected.

What it is: CVE-2024-43366 is a high-severity vulnerability in matter-labs era-compiler-vyper, published on 15 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43366 exists.

Affected product: matter-labs era-compiler-vyper. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43366/ (Markdown: https://insights.sbomify.com/CVE-2024-43366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43366
- OSV: https://osv.dev/vulnerability/CVE-2024-43366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43366/
Summaries are generated and may contain mistakes; the official description above is the record.
