{"answers":{"affected":"2 open source packages ship an affected version, including gettext.js.","exploited":"There is no known exploitation of CVE-2024-43370 in the wild and no public exploit code.","fix":"Upgrade gettext.js to 2.0.3 or later.","what":"CVE-2024-43370 is a high-severity cross-site scripting vulnerability in guillaumepotier gettext.js, published on 15 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-43370 and fix it if it is affected.\n\nWhat it is: CVE-2024-43370 is a high-severity cross-site scripting vulnerability in guillaumepotier gettext.js, published on 15 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-43370 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gettext.js (npm): affected all versions; fixed in 2.0.3\n- gettext.js (npm): affected all versions; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43370/ (Markdown: https://insights.sbomify.com/CVE-2024-43370/index.md)","id":"CVE-2024-43370","markdown":"https://insights.sbomify.com/CVE-2024-43370/index.md","name":"CVE-2024-43370","record":{"aliases":["DEBIAN-CVE-2024-43370","GHSA-vwhg-jwr4-vxgg","UBUNTU-CVE-2024-43370"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript i18n library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the browser if gettext.js processes corrupted .po dictionary files, affecting applications using this library.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"gettext.js is a GNU gettext port for node and the browser. There is a cross-site scripting (XSS) injection if `.po` dictionary definition files are corrupted. This vulnerability has been patched in version 2.0.3. As a workaround, control the origin of the definition catalog to prevent the use of this flaw in the definition of plural forms.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"gettext.js vulnerable to cross-site scripting (XSS)","id":"CVE-2024-43370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Potential access to sensitive URLs via CKAN extensions (SSRF)","id":"CVE-2024-43371"},"packages":[{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"gettext.js","purl":null,"source":"GHSA-vwhg-jwr4-vxgg"},{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"gettext.js","purl":"pkg:npm/gettext.js","source":"GHSA-vwhg-jwr4-vxgg"}],"prev":{"headline":"Persistent Cross-site Scripting in Ibexa RichText Field Type","id":"CVE-2024-43369"},"products":["gettext.js"],"published":"2024-08-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-16","vendors":["guillaumepotier"]},"summary":"An attacker can execute arbitrary scripts in the browser if gettext.js processes corrupted .po dictionary files, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2024-43370/"}