{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2024-43374 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-43374 is a medium-severity use after free vulnerability in Netapp Bootstrap Os, published on 15 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-43374 and fix it if it is affected.\n\nWhat it is: CVE-2024-43374 is a medium-severity use after free vulnerability in Netapp Bootstrap Os, published on 15 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-43374 in the wild and no public exploit code.\n\nAffected product: Netapp Bootstrap Os. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43374/ (Markdown: https://insights.sbomify.com/CVE-2024-43374/index.md)","id":"CVE-2024-43374","markdown":"https://insights.sbomify.com/CVE-2024-43374/index.md","name":"CVE-2024-43374","record":{"aliases":["ALPINE-CVE-2024-43374","AZL-47817","AZL-47832","BELL-CVE-2024-43374","CLSA-2024-1730133086","DEBIAN-CVE-2024-43374","ECHO-d1ca-6d1a-5e4d","GHSA-2w8m-443v-cgvw","OESA-2024-2026","ROOT-OS-ALPINE-318-CVE-2024-43374","ROOT-OS-ALPINE-319-CVE-2024-43374","UBUNTU-CVE-2024-43374"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Vim text editor","requires_auth":"none","summary":"A use-after-free in Vim's argument list handling allows a crash if malicious autocommands are triggered, requiring user interaction or malicious plugins.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"neovim","vendor":"neovim"},{"product":"bootstrap_os","vendor":"netapp"},{"product":"vim","vendor":"vim"}],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"The UNIX editor Vim prior to version 9.1.0678 has a use-after-free error in argument list handling. When adding a new file to the argument list, this triggers `Buf*` autocommands. If in such an autocommand the buffer that was just opened is closed (including the window where it is shown), this causes the window structure to be freed which contains a reference to the argument list that we are actually modifying. Once the autocommands are completed, the references to the window and argument list are no longer valid and as such cause an use-after-free. Impact is low since the user must either intentionally add some unusual autocommands that wipe a buffer during creation (either manually or by sourcing a malicious plugin), but it will crash Vim. The issue has been fixed as of Vim patch v9.1.0678.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vim heap-use-after-free in src/arglist.c:207","id":"CVE-2024-43374","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"netapp:bootstrap_os","products":["netapp:bootstrap_os","vim:vim"],"type":"use_after_free","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Umbraco CMS vulnerable to Generation of Error Message Containing Sensitive Information","id":"CVE-2024-43376"},"packages":[],"prev":{"headline":"webcrack has an Arbitrary File Write Vulnerability on Windows when Parsing and Saving a Malicious Bundle","id":"CVE-2024-43373"},"products":["vim"],"published":"2024-08-15","related":[{"cvss_score":8.6,"headline":"Command injection in n/a","id":"CVE-2019-12735","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":7.8,"headline":"Use After Free in vim/vim","id":"CVE-2022-3591","kev_date_added":null,"published":"2022-12-02"},{"cvss_score":6.6,"headline":"Vim: Heap Buffer Overflow in spell file loading","id":"CVE-2026-45130","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":6.6,"headline":"Heap Overflow in Vim","id":"CVE-2026-25749","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":4.2,"headline":"heap-buffer-overflow with visual mode in Vim \u003c 9.1.1003","id":"CVE-2025-22134","kev_date_added":null,"published":"2025-01-13"},{"cvss_score":4.2,"headline":"Vim \u003c v9.1.0648 has a double-free in dialog_changed()","id":"CVE-2024-41965","kev_date_added":null,"published":"2024-08-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-20","vendors":["vim"]},"summary":"A use-after-free in Vim's argument list handling allows a crash if malicious autocommands are triggered, requiring user interaction or malicious plugins.","url":"https://insights.sbomify.com/CVE-2024-43374/"}