# CVE-2024-43379: TruffleHog has a Blind SSRF in some Detectors


- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 19 Aug 2024
- **Updated:** 19 Aug 2024
- **Also known as:** GHSA-3r74-v83p-f4f4, GO-2024-3076

## What is CVE-2024-43379?

CVE-2024-43379 is a low-severity vulnerability in trufflesecurity trufflehog, published on 19 Aug 2024. 

### Official description

TruffleHog is a secrets scanning tool. Prior to v3.81.9, this vulnerability allows a malicious actor to craft data in a way that, when scanned by specific detectors, could trigger the detector to make an unauthorized request to an endpoint chosen by the attacker. For an exploit to be effective, the target endpoint must be an unauthenticated GET endpoint that produces side effects. The victim must scan the maliciously crafted data and have such an endpoint targeted for the exploit to succeed. The vulnerability has been resolved in TruffleHog v3.81.9 and later versions.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-43379?

4 open source packages ship an affected version, including github.com/trufflesecurity/trufflehog/v3 and github.com/trufflesecurity/trufflehog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/trufflesecurity/trufflehog/v3` | Go | All versions | 3.81.9 |
| `github.com/trufflesecurity/trufflehog/v3` | Go | All versions | 3.81.9 |
| `github.com/trufflesecurity/trufflehog/v3` | Go | All versions | 3.81.9 |
| `github.com/trufflesecurity/trufflehog` | Go | All versions | None |

Products: Trufflesecurity Trufflehog.

## How do I fix CVE-2024-43379?

Upgrade github.com/trufflesecurity/trufflehog/v3 to 3.81.9 or later.

## Is CVE-2024-43379 being exploited?

There is no known exploitation of CVE-2024-43379 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43379 and fix it if it is affected.

What it is: CVE-2024-43379 is a low-severity vulnerability in trufflesecurity trufflehog, published on 19 Aug 2024. 
Exploitation: There is no known exploitation of CVE-2024-43379 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/trufflesecurity/trufflehog/v3 (Go): affected all versions; fixed in 3.81.9
- github.com/trufflesecurity/trufflehog/v3 (Go): affected all versions; fixed in 3.81.9
- github.com/trufflesecurity/trufflehog/v3 (Go): affected all versions; fixed in 3.81.9
- github.com/trufflesecurity/trufflehog (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43379/ (Markdown: https://insights.sbomify.com/CVE-2024-43379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43379
- OSV: https://osv.dev/vulnerability/CVE-2024-43379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43379/
Summaries are generated and may contain mistakes; the official description above is the record.
