# CVE-2024-43380: fugit parse and parse_nat stall on lengthy input

> Attackers can cause denial of service by providing lengthy input to the fugit parser, which stalls the thread indefinitely.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2024
- **Updated:** 3 Sep 2024
- **Also known as:** DEBIAN-CVE-2024-43380, GHSA-2m96-52r3-2f3g, UBUNTU-CVE-2024-43380

## What is CVE-2024-43380?

CVE-2024-43380 is a medium-severity denial of service vulnerability in floraison fugit, published on 19 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fugit contains time tools for flor and the floraison group. The fugit "natural" parser, that turns "every wednesday at 5pm" into "0 17 * * 3", accepted any length of input and went on attempting to parse it, not returning promptly, as expected. The parse call could hold the thread with no end in sight. Fugit dependents that do not check (user) input length for plausibility are impacted. A fix was released in fugit 1.11.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-43380?

2 open source packages ship an affected version, including fugit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fugit` | RubyGems | All versions | 1.11.1 |
| `fugit` | RubyGems | All versions | 1.11.1 |

Products: Floraison Fugit.

## How do I fix CVE-2024-43380?

Upgrade fugit to 1.11.1 or later.

## Is CVE-2024-43380 being exploited?

There is no known exploitation of CVE-2024-43380 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43380 and fix it if it is affected.

What it is: CVE-2024-43380 is a medium-severity denial of service vulnerability in floraison fugit, published on 19 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43380 in the wild and no public exploit code.

Affected packages and fixed versions:
- fugit (RubyGems): affected all versions; fixed in 1.11.1
- fugit (RubyGems): affected all versions; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43380/ (Markdown: https://insights.sbomify.com/CVE-2024-43380/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43380
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43380
- OSV: https://osv.dev/vulnerability/CVE-2024-43380

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43380/
Summaries are generated and may contain mistakes; the official description above is the record.
