CVE-2024-43382 Snowflake JDBC Security Advisory

Medium 5.9 Published Updated

The Snowflake JDBC driver fails to apply client-side encryption to uploaded data, potentially exposing sensitive information to unauthorized readers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-43382?

CVE-2024-43382 is a medium-severity vulnerability in n/a, published on 30 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Snowflake JDBC driver versions >= 3.2.6 and <= 3.19.1 have an Incorrect Security Setting that can result in data being uploaded to an encrypted stage without the additional layer of protection provided by client side encryption.

Weakness: CWE-326

Which versions are affected by CVE-2024-43382?

2 open source packages ship an affected version, including net.snowflake:snowflake-jdbc. It affects 1 product.

PackageAffectedFixed in
net.snowflake:snowflake-jdbc MavenFrom 3.2.63.20.0
net.snowflake:snowflake-jdbc MavenFrom 3.2.63.20.0

Products include Snowflake Snowflake Jdbc.

How do I fix CVE-2024-43382?

Upgrade net.snowflake:snowflake-jdbc to 3.20.0 or later.

Is CVE-2024-43382 being exploited?

There is no known exploitation of CVE-2024-43382 in the wild and no public exploit code.

Sources

Also known as GHSA-f686-hw9c-xw9c.

Is CVE-2024-43382 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free