# CVE-2024-43394: Apache HTTP Server: SSRF on Windows due to UNC paths

> Attackers can leak NTLM hashes via SSRF on Windows Apache servers using mod_rewrite or expressions with unvalidated input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2024-43394, BELL-CVE-2024-43394, BIT-apache-2024-43394, DEBIAN-CVE-2024-43394, GHSA-gxxm-rhpx-j39m, MINI-2hf3-9w8x-wh3h

## What is CVE-2024-43394?

CVE-2024-43394 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) in Apache HTTP Server on Windows allows to potentially leak NTLM hashes to a malicious server via 
mod_rewrite or apache expressions that pass unvalidated request input.

This issue affects Apache HTTP Server: from 2.4.0 through 2.4.63.

Note:  The Apache HTTP Server Project will be setting a higher bar for accepting vulnerability reports regarding SSRF via UNC paths. 

The server offers limited protection against administrators directing the server to open UNC paths.
Windows servers should limit the hosts they will connect over via SMB based on the nature of NTLM authentication.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-43394?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.64 |

Products: Apache Http Server.

## How do I fix CVE-2024-43394?

Upgrade apache to 2.4.64 or later.

## Is CVE-2024-43394 being exploited?

There is no known exploitation of CVE-2024-43394 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43394 and fix it if it is affected.

What it is: CVE-2024-43394 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43394 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43394/ (Markdown: https://insights.sbomify.com/CVE-2024-43394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43394
- OSV: https://osv.dev/vulnerability/CVE-2024-43394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43394/
Summaries are generated and may contain mistakes; the official description above is the record.
