{"answers":{"affected":"2 open source packages ship an affected version, including rexml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-43398 in the wild and no public exploit code.","fix":"Upgrade rexml to 3.3.6 or later.","what":"CVE-2024-43398 is a medium-severity denial of service vulnerability in Netapp Bootstrap Os, published on 22 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-43398 and fix it if it is affected.\n\nWhat it is: CVE-2024-43398 is a medium-severity denial of service vulnerability in Netapp Bootstrap Os, published on 22 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-43398 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rexml (RubyGems): affected all versions; fixed in 3.3.6\n- rexml (RubyGems): affected all versions; fixed in 3.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43398/ (Markdown: https://insights.sbomify.com/CVE-2024-43398/index.md)","id":"CVE-2024-43398","markdown":"https://insights.sbomify.com/CVE-2024-43398/index.md","name":"CVE-2024-43398","record":{"aliases":["ALPINE-CVE-2024-43398","AZL-48150","AZL-48154","AZL-48156","AZL-48162","DEBIAN-CVE-2024-43398","ECHO-b3f2-b180-cac9","GHSA-vmwr-mc7x-5vc3","MINI-h522-p92r-4mxc","ROOT-APP-RUBY-CVE-2024-43398","UBUNTU-CVE-2024-43398"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML library","requires_auth":"none","summary":"Attackers can cause denial of service in Ruby applications by parsing untrusted XML with deep elements using the tree parser API.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"bootstrap_os","vendor":"netapp"},{"product":"rexml","vendor":"ruby-lang"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"REXML is an XML toolkit for Ruby. The REXML gem before 3.3.6 has a DoS vulnerability when it parses an XML that has many deep elements that have same local name attributes. If you need to parse untrusted XMLs with tree parser API like REXML::Document.new, you may be impacted to this vulnerability. If you use other parser APIs such as stream parser API and SAX2 parser API, this vulnerability is not affected. The REXML gem 3.3.6 or later include the patch to fix the vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"REXML denial of service vulnerability","id":"CVE-2024-43398","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"netapp:bootstrap_os","products":["netapp:bootstrap_os"],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Mobile Security Framework (MobSF) has a Zip Slip Vulnerability in .a Static Library Files","id":"CVE-2024-43399"},"packages":[{"ecosystem":"RubyGems","fixed":["3.3.6"],"introduced":["0"],"last_affected":[],"package":"rexml","purl":null,"source":"GHSA-vmwr-mc7x-5vc3"},{"ecosystem":"RubyGems","fixed":["3.3.6"],"introduced":["0"],"last_affected":[],"package":"rexml","purl":"pkg:gem/rexml","source":"GHSA-vmwr-mc7x-5vc3"}],"prev":{"headline":"Potential unauthorized access issue in apollo-portal","id":"CVE-2024-43397"},"products":["rexml"],"published":"2024-08-22","related":[{"cvss_score":4.8,"headline":"Security feature bypass in Oracle Java SE","id":"CVE-2025-30691","kev_date_added":null,"published":"2025-04-15"},{"cvss_score":4.5,"headline":"heap-buffer-overflow in do_search() in Vim \u003c 9.1.0689","id":"CVE-2024-43790","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.4,"headline":"Vim vulnerable to potential data loss with zip.vim and special crafted zip files","id":"CVE-2025-29768","kev_date_added":null,"published":"2025-03-13"},{"cvss_score":4.3,"headline":"Denial of service in REXML","id":"CVE-2024-39908","kev_date_added":null,"published":"2024-07-16"},{"cvss_score":3.9,"headline":"use-after-free when closing buffers in Vim","id":"CVE-2024-47814","kev_date_added":null,"published":"2024-10-07"},{"cvss_score":3.7,"headline":"Other in GraalVM","id":"CVE-2024-21211","kev_date_added":null,"published":"2024-10-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["ruby"]},"summary":"Attackers can cause denial of service in Ruby applications by parsing untrusted XML with deep elements using the tree parser API.","url":"https://insights.sbomify.com/CVE-2024-43398/"}