# CVE-2024-43400: XWiki Platform allows XSS through XClass name in string properties

> Attackers can inject arbitrary JavaScript via crafted URLs in XWiki, requiring user interaction to execute code in victim sessions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-wcg9-pgqv-xm5v

## What is CVE-2024-43400?

CVE-2024-43400 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 19 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible for a user without Script or Programming rights to craft a URL pointing to a page with arbitrary JavaScript. This requires social engineer to trick a user to follow the URL. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-96 (Improper Neutralization of Directives in Statically Saved Code)

## Which versions are affected by CVE-2024-43400?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.1.2 | 14.10.21 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.1.2 | 14.10.21 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.5.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.5.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.6-rc-1 | 15.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.6-rc-1 | 15.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.0.0-rc-1 | 16.0.0 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.0.0-rc-1 | 16.0.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-43400?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 14.10.21, 15.5.5, 15.10.6 or 16.0.0.

## Is CVE-2024-43400 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43400 exists.

Public exploit code:

- yasa (github_poc): https://github.com/rain321654/yasa-cve-2024-43400-main1
- https://github.com/rain321654/CVE-2024-43400 (github_poc): https://github.com/rain321654/CVE-2024-43400

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43400 and fix it if it is affected.

What it is: CVE-2024-43400 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 19 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43400 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.1.2; fixed in 14.10.21
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.1.2; fixed in 14.10.21
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.5.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.5.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.6-rc-1; fixed in 15.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.6-rc-1; fixed in 15.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.0.0-rc-1; fixed in 16.0.0
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.0.0-rc-1; fixed in 16.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43400/ (Markdown: https://insights.sbomify.com/CVE-2024-43400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43400
- OSV: https://osv.dev/vulnerability/CVE-2024-43400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43400/
Summaries are generated and may contain mistakes; the official description above is the record.
