# CVE-2024-43401: In XWiki Platform, payloads stored in content is executed when a user with script/programming right edit them

> Attackers can trick privileged users into executing malicious code by editing crafted content, leading to code execution and privilege escalation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-f963-4cq8-2gw7

## What is CVE-2024-43401?

CVE-2024-43401 is a critical code injection vulnerability in Xwiki Xwiki, published on 19 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A user without script/programming right can trick a user with elevated rights to edit a content with a malicious payload using a WYSIWYG editor. The user with elevated rights is not warned beforehand that they are going to edit possibly dangerous content. The payload is executed at edit time. This vulnerability has been patched in XWiki 15.10RC1.

Weakness: CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-43401?

2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | All versions | 15.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | All versions | 15.10-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-43401?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to 15.10-rc-1 or later.

## Is CVE-2024-43401 being exploited?

There is no known exploitation of CVE-2024-43401 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43401 and fix it if it is affected.

What it is: CVE-2024-43401 is a critical code injection vulnerability in Xwiki Xwiki, published on 19 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-43401 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected all versions; fixed in 15.10-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected all versions; fixed in 15.10-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43401/ (Markdown: https://insights.sbomify.com/CVE-2024-43401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43401
- OSV: https://osv.dev/vulnerability/CVE-2024-43401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43401/
Summaries are generated and may contain mistakes; the official description above is the record.
