# CVE-2024-43406: LF Edge eKuiper has a SQL Injection in sqlKvStore

> Attackers can execute malicious SQL queries via the Get method in sqlKvStore, potentially compromising data or executing code on edge devices.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2024
- **Updated:** 20 Aug 2024
- **Also known as:** GHSA-r5ph-4jxm-6j9p, GO-2024-3078, PYSEC-2024-72

## What is CVE-2024-43406?

CVE-2024-43406 is a high-severity SQL injection vulnerability in lf-edge ekuiper, published on 20 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LF Edge eKuiper is a lightweight IoT data analytics and stream processing engine running on resource-constraint edge devices. A user could utilize and exploit SQL Injection to allow the execution of malicious SQL query via Get method in sqlKvStore. This vulnerability is fixed in 1.14.2.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-43406?

6 open source packages ship an affected version, including github.com/lf-edge/ekuiper and ekuiper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lf-edge/ekuiper` | Go | All versions | 1.14.2 |
| `github.com/lf-edge/ekuiper` | Go | All versions | 1.14.2 |
| `github.com/lf-edge/ekuiper` | Go | All versions | 1.14.2 |
| `ekuiper` | PyPI | All versions | 1.14.2 |
| `ekuiper` | PyPI | All versions | 1.14.2 |
| `ekuiper` | PyPI | All versions | 1.14.2 |

Products: Lfedge Ekuiper.

## How do I fix CVE-2024-43406?

Upgrade github.com/lf-edge/ekuiper to 1.14.2 or later.

## Is CVE-2024-43406 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43406 exists.

## Other vulnerabilities in lf-edge ekuiper

- [CVE-2025-54379](https://insights.sbomify.com/CVE-2025-54379/): eKuiper API endpoints handling SQL queries with user-controlled table names. (high 8.9)
- [CVE-2024-52290](https://insights.sbomify.com/CVE-2024-52290/): Stored XSS in Configuration Key Functionality (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43406 and fix it if it is affected.

What it is: CVE-2024-43406 is a high-severity SQL injection vulnerability in lf-edge ekuiper, published on 20 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43406 exists.

Affected packages and fixed versions:
- github.com/lf-edge/ekuiper (Go): affected all versions; fixed in 1.14.2
- github.com/lf-edge/ekuiper (Go): affected all versions; fixed in 1.14.2
- github.com/lf-edge/ekuiper (Go): affected all versions; fixed in 1.14.2
- ekuiper (PyPI): affected all versions; fixed in 1.14.2
- ekuiper (PyPI): affected all versions; fixed in 1.14.2
- ekuiper (PyPI): affected all versions; fixed in 1.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43406/ (Markdown: https://insights.sbomify.com/CVE-2024-43406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43406
- OSV: https://osv.dev/vulnerability/CVE-2024-43406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43406/
Summaries are generated and may contain mistakes; the official description above is the record.
