{"answers":{"affected":"4 open source packages ship an affected version, including ckeditor4 and ckeditor/ckeditor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-43407 in the wild and no public exploit code.","fix":"Upgrade ckeditor4 to 4.25.0 or later.","what":"CVE-2024-43407 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-43407 and fix it if it is affected.\n\nWhat it is: CVE-2024-43407 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-43407 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckeditor4 (npm): affected all versions; fixed in 4.25.0\n- ckeditor4 (npm): affected all versions; fixed in 4.25.0\n- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.25.0\n- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.25.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43407/ (Markdown: https://insights.sbomify.com/CVE-2024-43407/index.md)","id":"CVE-2024-43407","markdown":"https://insights.sbomify.com/CVE-2024-43407/index.md","name":"CVE-2024-43407","record":{"aliases":["DEBIAN-CVE-2024-43407","GHSA-7r32-vfj5-c2jv","UBUNTU-CVE-2024-43407"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CKEditor 4 plugin","requires_auth":"none","summary":"Reflected XSS in CKEditor 4 Code Snippet GeSHi plugin allows attackers to execute malicious scripts via crafted requests to the hosted GeSHi library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor","vendor":"ckeditor"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A potential vulnerability has been discovered in CKEditor 4 Code Snippet GeSHi plugin. The vulnerability allowed a reflected XSS attack by exploiting a flaw in the GeSHi syntax highlighter library hosted by the victim. The GeSHi library was included as a vendor dependency in CKEditor 4 source files. In a specific scenario, an attacker could craft a malicious script that could be executed by sending a request to the GeSHi library hosted on a PHP web server. The GeSHi library is no longer actively maintained. Due to the lack of ongoing support and updates, potential security vulnerabilities have been identified with its continued use. To mitigate these risks and enhance the overall security of the CKEditor 4, we have decided to completely remove the GeSHi library as a dependency. This change aims to maintain a secure environment and reduce the risk of any security incidents related to outdated or unsupported software. The fix is be available in version 4.25.0-lts.","ecosystems":["Packagist","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code Snippet GeSHi plugin has reflected cross-site scripting (XSS) vulnerability","id":"CVE-2024-43407","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Discourse Placeholder Forms has a XSS stopped by CSP","id":"CVE-2024-43408"},"packages":[{"ecosystem":"Packagist","fixed":["4.25.0"],"introduced":["0"],"last_affected":[],"package":"ckeditor/ckeditor","purl":null,"source":"GHSA-7r32-vfj5-c2jv"},{"ecosystem":"Packagist","fixed":["4.25.0"],"introduced":["0"],"last_affected":[],"package":"ckeditor/ckeditor","purl":"pkg:composer/ckeditor/ckeditor","source":"GHSA-7r32-vfj5-c2jv"},{"ecosystem":"npm","fixed":["4.25.0"],"introduced":["0"],"last_affected":[],"package":"ckeditor4","purl":null,"source":"GHSA-7r32-vfj5-c2jv"},{"ecosystem":"npm","fixed":["4.25.0"],"introduced":["0"],"last_affected":[],"package":"ckeditor4","purl":"pkg:npm/ckeditor4","source":"GHSA-7r32-vfj5-c2jv"}],"prev":{"headline":"LF Edge eKuiper has a SQL Injection in sqlKvStore","id":"CVE-2024-43406"},"products":["ckeditor4"],"published":"2024-08-21","related":[{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2023-31541","kev_date_added":null,"published":"2023-06-13"},{"cvss_score":8.2,"headline":"Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML","id":"CVE-2021-41164","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":8.2,"headline":"HTML comments vulnerability allowing to execute JavaScript code","id":"CVE-2021-41165","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":7.6,"headline":"Cross-site scripting in ckeditor via abuse of undo functionality","id":"CVE-2021-32808","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":7.5,"headline":"Missing authorization in CKEditor Drupal module","id":"CVE-2011-4972","kev_date_added":null,"published":"2019-11-13"},{"cvss_score":7.3,"headline":"Execution of JavaScript code using malformed HTML in ckeditor","id":"CVE-2021-37695","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":6.8,"headline":"Code injection in n/a","id":"CVE-2012-2067","kev_date_added":null,"published":"2012-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-21","vendors":["ckeditor"]},"summary":"Reflected XSS in CKEditor 4 Code Snippet GeSHi plugin allows attackers to execute malicious scripts via crafted requests to the hosted GeSHi library.","url":"https://insights.sbomify.com/CVE-2024-43407/"}