# CVE-2024-43407: Code Snippet GeSHi plugin has reflected cross-site scripting (XSS) vulnerability

> Reflected XSS in CKEditor 4 Code Snippet GeSHi plugin allows attackers to execute malicious scripts via crafted requests to the hosted GeSHi library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2024
- **Updated:** 21 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-43407, GHSA-7r32-vfj5-c2jv, UBUNTU-CVE-2024-43407

## What is CVE-2024-43407?

CVE-2024-43407 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A potential vulnerability has been discovered in CKEditor 4 Code Snippet GeSHi plugin. The vulnerability allowed a reflected XSS attack by exploiting a flaw in the GeSHi syntax highlighter library hosted by the victim. The GeSHi library was included as a vendor dependency in CKEditor 4 source files. In a specific scenario, an attacker could craft a malicious script that could be executed by sending a request to the GeSHi library hosted on a PHP web server. The GeSHi library is no longer actively maintained. Due to the lack of ongoing support and updates, potential security vulnerabilities have been identified with its continued use. To mitigate these risks and enhance the overall security of the CKEditor 4, we have decided to completely remove the GeSHi library as a dependency. This change aims to maintain a secure environment and reduce the risk of any security incidents related to outdated or unsupported software. The fix is be available in version 4.25.0-lts.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-43407?

4 open source packages ship an affected version, including ckeditor4 and ckeditor/ckeditor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckeditor4` | npm | All versions | 4.25.0 |
| `ckeditor4` | npm | All versions | 4.25.0 |
| `ckeditor/ckeditor` | Packagist | All versions | 4.25.0 |
| `ckeditor/ckeditor` | Packagist | All versions | 4.25.0 |

Products: Ckeditor Ckeditor.

## How do I fix CVE-2024-43407?

Upgrade ckeditor4 to 4.25.0 or later.

## Is CVE-2024-43407 being exploited?

There is no known exploitation of CVE-2024-43407 in the wild and no public exploit code.

## Other vulnerabilities in ckeditor4

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43407 and fix it if it is affected.

What it is: CVE-2024-43407 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-43407 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckeditor4 (npm): affected all versions; fixed in 4.25.0
- ckeditor4 (npm): affected all versions; fixed in 4.25.0
- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.25.0
- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43407/ (Markdown: https://insights.sbomify.com/CVE-2024-43407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43407
- OSV: https://osv.dev/vulnerability/CVE-2024-43407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43407/
Summaries are generated and may contain mistakes; the official description above is the record.
