{"answers":{"affected":"2 open source packages ship an affected version, including russh. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43410 exists.","fix":"Upgrade russh to 0.44.1 or later.","what":"CVE-2024-43410 is a high-severity denial of service vulnerability in Eugeny russh, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-43410 and fix it if it is affected.\n\nWhat it is: CVE-2024-43410 is a high-severity denial of service vulnerability in Eugeny russh, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43410 exists.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected all versions; fixed in 0.44.1\n- russh (crates.io): affected all versions; fixed in 0.44.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43410/ (Markdown: https://insights.sbomify.com/CVE-2024-43410/index.md)","id":"CVE-2024-43410","markdown":"https://insights.sbomify.com/CVE-2024-43410/index.md","name":"CVE-2024-43410","record":{"aliases":["GHSA-vgvv-x7xg-6cqg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust SSH library","requires_auth":"none","summary":"Unauthenticated attackers can cause a denial of service in Russh SSH servers by sending packets with maliciously large length fields, triggering out-of-memory errors.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"russh","vendor":"russh_project"},{"product":"warpgate","vendor":"warpgate_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Russh is a Rust SSH client \u0026 server library. Allocating an untrusted amount of memory allows any unauthenticated user to OOM a russh server. An SSH packet consists of a 4-byte big-endian length, followed by a byte stream of this length.\nAfter parsing and potentially decrypting the 4-byte length, russh allocates enough memory for this bytestream, as a performance optimization to avoid reallocations later. But this length is entirely untrusted and can be set to any value by the client, causing this much memory to be allocated, which will cause the process to OOM within a few such requests. This vulnerability is fixed in 0.44.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Russh has an OOM Denial of Service due to allocation of untrusted amount","id":"CVE-2024-43410","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"CKEditor4 has a low risk cross-site scripting (XSS) vulnerability from domain takeover","id":"CVE-2024-43411"},"packages":[{"ecosystem":"crates.io","fixed":["0.44.1"],"introduced":["0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-vgvv-x7xg-6cqg"},{"ecosystem":"crates.io","fixed":["0.44.1"],"introduced":["0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-vgvv-x7xg-6cqg"}],"prev":{"headline":"Ghost's improper authentication allows access to member information and actions","id":"CVE-2024-43409"},"products":["russh"],"published":"2024-08-21","related":[{"cvss_score":7.5,"headline":"Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth","id":"CVE-2026-42189","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":6.5,"headline":"Russh is missing an overflow check during channel windows adjust","id":"CVE-2025-54804","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":5.9,"headline":"russh may use insecure Diffie-Hellman keys","id":"CVE-2023-28113","kev_date_added":null,"published":"2023-03-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-21","vendors":["Eugeny"]},"summary":"Unauthenticated attackers can cause a denial of service in Russh SSH servers by sending packets with maliciously large length fields, triggering out-of-memory errors.","url":"https://insights.sbomify.com/CVE-2024-43410/"}