# CVE-2024-43410: Russh has an OOM Denial of Service due to allocation of untrusted amount

> Unauthenticated attackers can cause a denial of service in Russh SSH servers by sending packets with maliciously large length fields, triggering out-of-memory errors.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-vgvv-x7xg-6cqg

## What is CVE-2024-43410?

CVE-2024-43410 is a high-severity denial of service vulnerability in Eugeny russh, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. Allocating an untrusted amount of memory allows any unauthenticated user to OOM a russh server. An SSH packet consists of a 4-byte big-endian length, followed by a byte stream of this length.
After parsing and potentially decrypting the 4-byte length, russh allocates enough memory for this bytestream, as a performance optimization to avoid reallocations later. But this length is entirely untrusted and can be set to any value by the client, causing this much memory to be allocated, which will cause the process to OOM within a few such requests. This vulnerability is fixed in 0.44.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-43410?

2 open source packages ship an affected version, including russh. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.44.1 |
| `russh` | crates.io | All versions | 0.44.1 |

Products: Russh Project Russh, Warpgate Project Warpgate.

## How do I fix CVE-2024-43410?

Upgrade russh to 0.44.1 or later.

## Is CVE-2024-43410 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43410 exists.

## Other vulnerabilities in Eugeny russh

- [CVE-2026-42189](https://insights.sbomify.com/CVE-2026-42189/): Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth (high 7.5)
- [CVE-2025-54804](https://insights.sbomify.com/CVE-2025-54804/): Russh is missing an overflow check during channel windows adjust (medium 6.5)
- [CVE-2023-28113](https://insights.sbomify.com/CVE-2023-28113/): russh may use insecure Diffie-Hellman keys (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43410 and fix it if it is affected.

What it is: CVE-2024-43410 is a high-severity denial of service vulnerability in Eugeny russh, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43410 exists.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.44.1
- russh (crates.io): affected all versions; fixed in 0.44.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43410/ (Markdown: https://insights.sbomify.com/CVE-2024-43410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43410
- OSV: https://osv.dev/vulnerability/CVE-2024-43410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43410/
Summaries are generated and may contain mistakes; the official description above is the record.
