{"answers":{"affected":"2 open source packages ship an affected version, including ckeditor4.","exploited":"There is no known exploitation of CVE-2024-43411 in the wild and no public exploit code.","fix":"Upgrade ckeditor4 to 4.25.0 or later.","what":"CVE-2024-43411 is a low-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-43411 and fix it if it is affected.\n\nWhat it is: CVE-2024-43411 is a low-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-43411 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckeditor4 (npm): affected from 4.22.0; fixed in 4.25.0\n- ckeditor4 (npm): affected from 4.22.0; fixed in 4.25.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43411/ (Markdown: https://insights.sbomify.com/CVE-2024-43411/index.md)","id":"CVE-2024-43411","markdown":"https://insights.sbomify.com/CVE-2024-43411/index.md","name":"CVE-2024-43411","record":{"aliases":["GHSA-6v96-m24v-f58j","UBUNTU-CVE-2024-43411"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"CKEditor4 HTML editor","requires_auth":"high_privilege","summary":"An attacker controlling the CKEditor domain could inject scripts into editors with version notifications enabled, requiring an upgrade to fix.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. The issue impacts only editor instances with enabled version notifications. Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us. The fix is available in version 4.25.0-lts.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CKEditor4 has a low risk cross-site scripting (XSS) vulnerability from domain takeover","id":"CVE-2024-43411","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Xibo CMS XSS vulnerability when previewing files uploaded to the library containing HTML/JS","id":"CVE-2024-43412"},"packages":[{"ecosystem":"npm","fixed":["4.25.0"],"introduced":["4.22.0"],"last_affected":[],"package":"ckeditor4","purl":null,"source":"GHSA-6v96-m24v-f58j"},{"ecosystem":"npm","fixed":["4.25.0"],"introduced":["4.22.0"],"last_affected":[],"package":"ckeditor4","purl":"pkg:npm/ckeditor4","source":"GHSA-6v96-m24v-f58j"}],"prev":{"headline":"Russh has an OOM Denial of Service due to allocation of untrusted amount","id":"CVE-2024-43410"},"products":["ckeditor4"],"published":"2024-08-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-22","vendors":["ckeditor"]},"summary":"An attacker controlling the CKEditor domain could inject scripts into editors with version notifications enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2024-43411/"}