# CVE-2024-43411: CKEditor4 has a low risk cross-site scripting (XSS) vulnerability from domain takeover

> An attacker controlling the CKEditor domain could inject scripts into editors with version notifications enabled, requiring an upgrade to fix.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-6v96-m24v-f58j, UBUNTU-CVE-2024-43411

## What is CVE-2024-43411?

CVE-2024-43411 is a low-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. The issue impacts only editor instances with enabled version notifications. Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us. The fix is available in version 4.25.0-lts.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-43411?

2 open source packages ship an affected version, including ckeditor4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckeditor4` | npm | From 4.22.0 | 4.25.0 |
| `ckeditor4` | npm | From 4.22.0 | 4.25.0 |

## How do I fix CVE-2024-43411?

Upgrade ckeditor4 to 4.25.0 or later.

## Is CVE-2024-43411 being exploited?

There is no known exploitation of CVE-2024-43411 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43411 and fix it if it is affected.

What it is: CVE-2024-43411 is a low-severity cross-site scripting vulnerability in ckeditor4, published on 21 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-43411 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckeditor4 (npm): affected from 4.22.0; fixed in 4.25.0
- ckeditor4 (npm): affected from 4.22.0; fixed in 4.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43411/ (Markdown: https://insights.sbomify.com/CVE-2024-43411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43411
- OSV: https://osv.dev/vulnerability/CVE-2024-43411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43411/
Summaries are generated and may contain mistakes; the official description above is the record.
