# CVE-2024-43414: Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries

> Attackers can cause denial of service in Apollo GraphQL services by submitting complex queries that trigger infinite loops and memory exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2024
- **Updated:** 27 Aug 2024
- **Also known as:** GHSA-fmj9-77q8-g6c4, ROOT-APP-NPM-CVE-2024-43414

## What is CVE-2024-43414?

CVE-2024-43414 is a high-severity denial of service vulnerability in apollographql federation, published on 27 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apollo Federation is an architecture for declaratively composing APIs into a unified graph. Each team can own their slice of the graph independently, empowering them to deliver autonomously and incrementally. Instances of @apollo/query-planner >=2.0.0 and <2.8.5 are impacted by a denial-of-service vulnerability. @apollo/gateway versions >=2.0.0 and < 2.8.5 and Apollo Router <1.52.1 are also impacted through their use of @apollo/query-panner. If @apollo/query-planner is asked to plan a sufficiently complex query, it may loop infinitely and never complete. This results in unbounded memory consumption and either a crash or out-of-memory (OOM) termination. This issue can be triggered if you have at least one non-@key field that can be resolved by multiple subgraphs. To identify these shared fields, the schema for each subgraph must be reviewed. The mechanism to identify shared fields varies based on the version of Federation your subgraphs are using. You can check if your subgraphs are using Federation 1 or Federation 2 by reviewing their schemas. Federation 2 subgraph schemas will contain a @link directive referencing the version of Federation being used while Federation 1 subgraphs will not. For example, in a Federation 2 subgraph, you will find a line like @link(url: "https://specs.apollo.dev/federation/v2.0"). If a similar @link directive is not present in your subgraph schema, it is using Federation 1. Note that a supergraph can contain a mix of Federation 1 and Federation 2 subgraphs. This issue results from the Apollo query planner attempting to use a Number exceeding Javascript’s Number.MAX_VALUE in some cases. In Javascript, Number.MAX_VALUE is (2^1024 - 2^971). When the query planner receives an inbound graphql request, it breaks the query into pieces and for each piece, generates a list of potential execution steps to solve the piece. These candidates represent the steps that the query planner will take to satisfy the pieces of the larger query. As part of normal operations, the query planner requires and calculates the number of possible query plans for the total query. That is, it needs the product of the number of query plan candidates for each piece of the query. Under normal circumstances, after generating all query plan candidates and calculating the number of all permutations, the query planner moves on to stack rank candidates and prune less-than-optimal options. In particularly complex queries, especially those where fields can be solved through multiple subgraphs, this can cause the number of all query plan permutations to balloon. In worst-case scenarios, this can end up being a number larger than Number.MAX_VALUE. In Javascript, if Number.MAX_VALUE is exceeded, Javascript represents the value as “infinity”. If the count of candidates is evaluated as infinity, the component of the query planner responsible for pruning less-than-optimal query plans does not actually prune candidates, causing the query planner to evaluate many orders of magnitude more query plan candidates than necessary. This issue has been addressed in @apollo/query-planner v2.8.5, @apollo/gateway v2.8.5, and Apollo Router v1.52.1. Users are advised to upgrade. This issue can be avoided by ensuring there are no fields resolvable from multiple subgraphs. If all subgraphs are using Federation 2, you can confirm that you are not impacted by ensuring that none of your subgraph schemas use the @shareable directive. If you are using Federation 1 subgraphs, you will need to validate that there are no fields resolvable by multiple subgraphs.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-43414?

6 open source packages ship an affected version, including apollo-router, @apollo/gateway and @apollo/query-planner. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apollo-router` | crates.io | All versions | 1.52.1 |
| `apollo-router` | crates.io | All versions | 1.52.1 |
| `@apollo/gateway` | npm | From 2.0.0 | 2.8.5 |
| `@apollo/gateway` | npm | From 2.0.0 | 2.8.5 |
| `@apollo/query-planner` | npm | From 2.0.0 | 2.8.5 |
| `@apollo/query-planner` | npm | From 2.0.0 | 2.8.5 |

Products: Apollographql Apollo-Router, Apollographql Apollo Gateway, Apollographql Apollo Helms-Charts Router, Apollographql Apollo Query-Planner, Apollographql Apollo Router.

## How do I fix CVE-2024-43414?

Upgrade apollo-router to 1.52.1 or later.

## Is CVE-2024-43414 being exploited?

There is no known exploitation of CVE-2024-43414 in the wild and no public exploit code.

## Other vulnerabilities in apollographql federation

- [CVE-2024-43783](https://insights.sbomify.com/CVE-2024-43783/): Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43414 and fix it if it is affected.

What it is: CVE-2024-43414 is a high-severity denial of service vulnerability in apollographql federation, published on 27 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43414 in the wild and no public exploit code.

Affected packages and fixed versions:
- apollo-router (crates.io): affected all versions; fixed in 1.52.1
- apollo-router (crates.io): affected all versions; fixed in 1.52.1
- @apollo/gateway (npm): affected from 2.0.0; fixed in 2.8.5
- @apollo/gateway (npm): affected from 2.0.0; fixed in 2.8.5
- @apollo/query-planner (npm): affected from 2.0.0; fixed in 2.8.5
- @apollo/query-planner (npm): affected from 2.0.0; fixed in 2.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43414/ (Markdown: https://insights.sbomify.com/CVE-2024-43414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43414
- OSV: https://osv.dev/vulnerability/CVE-2024-43414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43414/
Summaries are generated and may contain mistakes; the official description above is the record.
