CVE-2024-43415 Decidim-Awesome: SQL injection in AdminAccountability
An authenticated admin can exploit SQL injection in the Decidim Awesome module to disclose data, read/write files, or execute commands.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43415?
CVE-2024-43415 is a critical SQL injection vulnerability in decidim-ice decidim-module-decidim_awesome, published on 12 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An improper neutralization of special elements used in an SQL command in the papertrail/version- model of the decidim_awesome-module <= v0.11.1 (> 0.9.0) allows an authenticated admin user to manipulate sql queries to disclose information, read and write files or execute commands.
Weakness: CWE-89
Which versions are affected by CVE-2024-43415?
4 open source packages ship an affected version, including decidim-decidim_awesome.
| Package | Affected | Fixed in |
|---|---|---|
decidim-decidim_awesome RubyGems | From 0.11.0 | 0.11.2 |
decidim-decidim_awesome RubyGems | From 0.11.0 | 0.11.2 |
decidim-decidim_awesome RubyGems | From 0.9.1 | 0.10.3 |
decidim-decidim_awesome RubyGems | From 0.9.1 | 0.10.3 |
How do I fix CVE-2024-43415?
Upgrade decidim-decidim_awesome to a fixed version for your release line: 0.11.2 or 0.10.3.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2024-43415 being exploited?
There is no known exploitation of CVE-2024-43415 in the wild and no public exploit code.
Sources
Also known as GHSA-cxwf-qc32-375f.