# CVE-2024-43415: Decidim-Awesome: SQL injection in AdminAccountability

> An authenticated admin can exploit SQL injection in the Decidim Awesome module to disclose data, read/write files, or execute commands.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-cxwf-qc32-375f

## What is CVE-2024-43415?

CVE-2024-43415 is a critical SQL injection vulnerability in decidim-ice decidim-module-decidim_awesome, published on 12 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An improper neutralization of special elements used in an SQL command in the papertrail/version- model of the decidim_awesome-module <= v0.11.1 (> 0.9.0) allows an authenticated admin user to manipulate sql queries to disclose information, read and write files or execute commands.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-43415?

4 open source packages ship an affected version, including decidim-decidim_awesome.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-decidim_awesome` | RubyGems | From 0.11.0 | 0.11.2 |
| `decidim-decidim_awesome` | RubyGems | From 0.11.0 | 0.11.2 |
| `decidim-decidim_awesome` | RubyGems | From 0.9.1 | 0.10.3 |
| `decidim-decidim_awesome` | RubyGems | From 0.9.1 | 0.10.3 |

## How do I fix CVE-2024-43415?

Upgrade decidim-decidim_awesome to a fixed version for your release line: 0.11.2 or 0.10.3.

## Is CVE-2024-43415 being exploited?

There is no known exploitation of CVE-2024-43415 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43415 and fix it if it is affected.

What it is: CVE-2024-43415 is a critical SQL injection vulnerability in decidim-ice decidim-module-decidim_awesome, published on 12 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43415 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-decidim_awesome (RubyGems): affected from 0.11.0; fixed in 0.11.2
- decidim-decidim_awesome (RubyGems): affected from 0.11.0; fixed in 0.11.2
- decidim-decidim_awesome (RubyGems): affected from 0.9.1; fixed in 0.10.3
- decidim-decidim_awesome (RubyGems): affected from 0.9.1; fixed in 0.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43415/ (Markdown: https://insights.sbomify.com/CVE-2024-43415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43415
- OSV: https://osv.dev/vulnerability/CVE-2024-43415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43415/
Summaries are generated and may contain mistakes; the official description above is the record.
