# CVE-2024-43425: Moodle: remote code execution via calculated question types

> Attackers with question management capabilities can achieve remote code execution in Moodle via calculated question types.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2024
- **Updated:** 7 Nov 2024
- **Also known as:** BIT-moodle-2024-43425, GHSA-v6f4-v8h8-3c87, UBUNTU-CVE-2024-43425

## What is CVE-2024-43425?

CVE-2024-43425 is a high-severity code injection vulnerability in Moodle Moodle, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-43425?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.12 |
| `moodle/moodle` | Packagist | All versions | 4.1.12 |
| `moodle/moodle` | Packagist | From 4.2.0-beta | 4.2.9 |
| `moodle/moodle` | Packagist | From 4.2.0-beta | 4.2.9 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.6 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.6 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.2 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.2 |
| `moodle` | Bitnami | All versions | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |

Products: Moodle Moodle.

## How do I fix CVE-2024-43425?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.

## Is CVE-2024-43425 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43425 exists.

Public exploit code:

- Scripts for Analysis of a RCE in Moodle Calculated Questions (CVE-2024-43425) (github_poc): https://github.com/RedTeamPentesting/moodle-rce-calculatedquestions
- https://github.com/Snizi/Moodle-CVE-2024-43425-Exploit (github_poc): https://github.com/Snizi/Moodle-CVE-2024-43425-Exploit
- 🚀 Exploit for Moodle 4.4.0 Authenticated RCE (CVE-2024-43425) — run commands remotely ⚡ (github_poc): https://github.com/kazuya256/Moodle-authenticated-RCE
- Moodle Remote Code Execution (CVE-2024-43425) (metasploit)
- https://github.com/aninfosec/CVE-2024-43425-Poc (github_poc): https://github.com/aninfosec/CVE-2024-43425-Poc
- Moodle 4.4.0 - Authenticated Remote Code Execution (exploitdb)

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43425 and fix it if it is affected.

What it is: CVE-2024-43425 is a high-severity code injection vulnerability in Moodle Moodle, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43425 exists.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.12
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.12
- moodle/moodle (Packagist): affected from 4.2.0-beta; fixed in 4.2.9
- moodle/moodle (Packagist): affected from 4.2.0-beta; fixed in 4.2.9
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.6
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.6
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.2
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.2
- moodle (Bitnami): affected all versions; fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43425/ (Markdown: https://insights.sbomify.com/CVE-2024-43425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43425
- OSV: https://osv.dev/vulnerability/CVE-2024-43425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43425/
Summaries are generated and may contain mistakes; the official description above is the record.
