CVE-2024-43429 Moodle: user information visibility control issues in gradebook reports
Attackers can view hidden user profile fields in gradebook reports, exposing sensitive personal information to unauthorized users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43429?
CVE-2024-43429 is a medium-severity vulnerability in Moodle Moodle, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in moodle. Some hidden user profile fields are visible in gradebook reports, which could result in users without the "view hidden user fields" capability having access to the information.
Weakness: CWE-312
Which versions are affected by CVE-2024-43429?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | From 4.2.0 | 4.2.9 |
moodle/moodle Packagist | From 4.2.0 | 4.2.9 |
moodle/moodle Packagist | From 4.3.0 | 4.3.6 |
moodle/moodle Packagist | From 4.3.0 | 4.3.6 |
3 more packages
moodle/moodle Packagist | From 4.4.0 | 4.4.2 |
moodle/moodle Packagist | From 4.4.0 | 4.4.2 |
moodle Bitnami | All versions | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2024-43429?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.
Is CVE-2024-43429 being exploited?
There is no known exploitation of CVE-2024-43429 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-43429, GHSA-c767-4whh-v7rw, UBUNTU-CVE-2024-43429.