CVE-2024-43431 Moodle: idor in badges allows deletion of arbitrary badges
Attackers can delete arbitrary badges in Moodle due to insufficient capability checks, requiring immediate patching by administrators.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43431?
CVE-2024-43431 is a high-severity missing authorization vulnerability in Moodle Moodle, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was found in Moodle. Insufficient capability checks made it possible to delete badges that a user does not have permission to access.
Weakness: CWE-862
Which versions are affected by CVE-2024-43431?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.9 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.9 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.6 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.6 |
3 more packages
moodle/moodle Packagist | From 4.4.0-beta | 4.4.2 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.2 |
moodle Bitnami | All versions | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2024-43431?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-43431 being exploited?
There is no known exploitation of CVE-2024-43431 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-43431, GHSA-wwjf-gwrv-wh45, UBUNTU-CVE-2024-43431.