# CVE-2024-43432: Moodle: authorization headers preserved between "emulated redirects"

> Attackers can intercept HTTP authorization headers leaked to redirect URLs due to improper header stripping in Moodle's cURL wrapper.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Nov 2024
- **Updated:** 12 Nov 2024
- **Also known as:** BIT-moodle-2024-43432, GHSA-7wmp-2xmx-g6h8, UBUNTU-CVE-2024-43432

## What is CVE-2024-43432?

CVE-2024-43432 is a medium-severity vulnerability in Moodle Moodle, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in moodle. The cURL wrapper in Moodle strips HTTPAUTH and USERPWD headers during emulated redirects, but retains other original request headers, so HTTP authorization header information could be unintentionally sent in requests to redirect URLs.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2024-43432?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.12 |
| `moodle/moodle` | Packagist | All versions | 4.1.12 |
| `moodle/moodle` | Packagist | From 4.2.0 | 4.2.9 |
| `moodle/moodle` | Packagist | From 4.2.0 | 4.2.9 |
| `moodle/moodle` | Packagist | From 4.3.0 | 4.3.6 |
| `moodle/moodle` | Packagist | From 4.3.0 | 4.3.6 |
| `moodle/moodle` | Packagist | From 4.4.0 | 4.4.2 |
| `moodle/moodle` | Packagist | From 4.4.0 | 4.4.2 |
| `moodle` | Bitnami | All versions | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |

Products: Moodle Moodle.

## How do I fix CVE-2024-43432?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.

## Is CVE-2024-43432 being exploited?

There is no known exploitation of CVE-2024-43432 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43432 and fix it if it is affected.

What it is: CVE-2024-43432 is a medium-severity vulnerability in Moodle Moodle, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43432 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.12
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.12
- moodle/moodle (Packagist): affected from 4.2.0; fixed in 4.2.9
- moodle/moodle (Packagist): affected from 4.2.0; fixed in 4.2.9
- moodle/moodle (Packagist): affected from 4.3.0; fixed in 4.3.6
- moodle/moodle (Packagist): affected from 4.3.0; fixed in 4.3.6
- moodle/moodle (Packagist): affected from 4.4.0; fixed in 4.4.2
- moodle/moodle (Packagist): affected from 4.4.0; fixed in 4.4.2
- moodle (Bitnami): affected all versions; fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43432/ (Markdown: https://insights.sbomify.com/CVE-2024-43432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43432
- OSV: https://osv.dev/vulnerability/CVE-2024-43432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43432/
Summaries are generated and may contain mistakes; the official description above is the record.
