CVE-2024-43435 Moodle: can create global glossary without being admin
Users with course glossary restore permissions can improperly add entries to the global site glossary due to insufficient capability checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43435?
CVE-2024-43435 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in moodle. Insufficient capability checks make it possible for users with access to restore glossaries in courses to restore them into the global site glossary.
Weakness: CWE-754
Which versions are affected by CVE-2024-43435?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | From 4.2.0 | 4.2.9 |
moodle/moodle Packagist | From 4.2.0 | 4.2.9 |
moodle/moodle Packagist | From 4.3.0 | 4.3.6 |
moodle/moodle Packagist | From 4.3.0 | 4.3.6 |
3 more packages
moodle/moodle Packagist | From 4.4.0 | 4.4.2 |
moodle/moodle Packagist | From 4.4.0 | 4.4.2 |
moodle Bitnami | All versions | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2024-43435?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-43435 being exploited?
There is no known exploitation of CVE-2024-43435 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-43435, GHSA-4gq2-x5w4-7hp8, UBUNTU-CVE-2024-43435.