CVE-2024-43436 Moodle: site administration sql injection via xmldb editor
Site administrators can exploit SQL injection in the XMLDB editor to read or modify database contents.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43436?
CVE-2024-43436 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 7 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A SQL injection risk flaw was found in the XMLDB editor tool available to site administrators.
Weakness: CWE-89
Which versions are affected by CVE-2024-43436?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.9 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.9 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.6 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.6 |
3 more packages
moodle/moodle Packagist | From 4.4.0-beta | 4.4.2 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.2 |
moodle Bitnami | From 4.1.0 | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2024-43436?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2024-43436 being exploited?
There is no known exploitation of CVE-2024-43436 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-43436, GHSA-mx26-62xm-2p83, UBUNTU-CVE-2024-43436.