{"answers":{"affected":"9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-43436 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.","what":"CVE-2024-43436 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 7 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-43436 and fix it if it is affected.\n\nWhat it is: CVE-2024-43436 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 7 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-43436 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 4.1.12\n- moodle/moodle (Packagist): affected all versions; fixed in 4.1.12\n- moodle/moodle (Packagist): affected from 4.2.0-beta; fixed in 4.2.9\n- moodle/moodle (Packagist): affected from 4.2.0-beta; fixed in 4.2.9\n- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.6\n- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.6\n- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.2\n- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.2\n- moodle (Bitnami): affected from 4.1.0; fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43436/ (Markdown: https://insights.sbomify.com/CVE-2024-43436/index.md)","id":"CVE-2024-43436","markdown":"https://insights.sbomify.com/CVE-2024-43436/index.md","name":"CVE-2024-43436","record":{"aliases":["BIT-moodle-2024-43436","GHSA-mx26-62xm-2p83","UBUNTU-CVE-2024-43436"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"high_privilege","summary":"Site administrators can exploit SQL injection in the XMLDB editor to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A SQL injection risk flaw was found in the XMLDB editor tool available to site administrators.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle: site administration sql injection via xmldb editor","id":"CVE-2024-43436","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"sql_injection","year":"2024"},"n_packages":9,"n_references":2,"next":{"headline":"Moodle: xss risk when restoring malicious course backup file","id":"CVE-2024-43437"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.12","4.2.9","4.3.6","4.4.2"],"introduced":["4.1.0","4.2.0","4.3.0","4.4.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2024-43436"},{"ecosystem":"Packagist","fixed":["4.1.12"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.1.12"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.2.9"],"introduced":["4.2.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.2.9"],"introduced":["4.2.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.3.6"],"introduced":["4.3.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.3.6"],"introduced":["4.3.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.4.2"],"introduced":["4.4.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-mx26-62xm-2p83"},{"ecosystem":"Packagist","fixed":["4.4.2"],"introduced":["4.4.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-mx26-62xm-2p83"}],"prev":{"headline":"Moodle: can create global glossary without being admin","id":"CVE-2024-43435"},"products":["moodle:moodle"],"published":"2024-11-07","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-07","vendors":["moodle"]},"summary":"Site administrators can exploit SQL injection in the XMLDB editor to read or modify database contents.","url":"https://insights.sbomify.com/CVE-2024-43436/"}