CVE-2024-43439 Moodle: reflected xss via h5p error message
Attackers can execute arbitrary scripts in victim browsers via unsanitized H5P error messages in Moodle, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-43439?
CVE-2024-43439 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 11 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in moodle. H5P error messages require additional sanitizing to prevent a reflected cross-site scripting (XSS) risk.
Weakness: CWE-79
Which versions are affected by CVE-2024-43439?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | All versions | 4.1.12 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.9 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.9 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.6 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.6 |
3 more packages
moodle/moodle Packagist | From 4.4.0-beta | 4.4.2 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.2 |
moodle Bitnami | All versions | 4.1.12, 4.2.9, 4.3.6, 4.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2024-43439?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.12, 4.2.9, 4.3.6 or 4.4.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-43439 being exploited?
There is no known exploitation of CVE-2024-43439 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-43439, GHSA-hjgc-jxjc-8v9j, UBUNTU-CVE-2024-43439.