# CVE-2024-43441: Apache HugeGraph-Server: Fixed JWT Token(Secret)


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Dec 2024
- **Updated:** 31 Dec 2024
- **Also known as:** GHSA-f697-gm3h-xrf9

## What is CVE-2024-43441?

CVE-2024-43441 is a critical vulnerability in Apache HugeGraph-Server, published on 24 Dec 2024. 

### Official description

Authentication Bypass by Assumed-Immutable Data vulnerability in Apache HugeGraph-Server.

This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.5.0.

Users are recommended to upgrade to version 1.5.0, which fixes the issue.

Weakness: CWE-302 (Authentication Bypass by Assumed-Immutable Data)

## Which versions are affected by CVE-2024-43441?

2 open source packages ship an affected version, including org.apache.hugegraph:hugegraph-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hugegraph:hugegraph-server` | Maven | From 1.0.0 | 1.5.0 |
| `org.apache.hugegraph:hugegraph-server` | Maven | From 1.0.0 | 1.5.0 |

Products: Apache Hugegraph.

## How do I fix CVE-2024-43441?

Upgrade org.apache.hugegraph:hugegraph-server to 1.5.0 or later.

## Is CVE-2024-43441 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43441 exists.

Public exploit code:

- Apache HugeGraph-Server <1.5.0 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-43441.yaml

## Other vulnerabilities in Apache HugeGraph-Server

- [CVE-2024-27348](https://insights.sbomify.com/CVE-2024-27348/): Apache HugeGraph-Server Improper Access Control (critical 9.8, exploited in the wild)
- [CVE-2024-27349](https://insights.sbomify.com/CVE-2024-27349/): Apache HugeGraph-Server: Bypass whitelist in Auth mode (critical 9.1)
- [CVE-2025-26866](https://insights.sbomify.com/CVE-2025-26866/): Apache HugeGraph-Server: RAFT and deserialization vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43441 and fix it if it is affected.

What it is: CVE-2024-43441 is a critical vulnerability in Apache HugeGraph-Server, published on 24 Dec 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43441 exists.

Affected packages and fixed versions:
- org.apache.hugegraph:hugegraph-server (Maven): affected from 1.0.0; fixed in 1.5.0
- org.apache.hugegraph:hugegraph-server (Maven): affected from 1.0.0; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43441/ (Markdown: https://insights.sbomify.com/CVE-2024-43441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43441
- OSV: https://osv.dev/vulnerability/CVE-2024-43441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43441/
Summaries are generated and may contain mistakes; the official description above is the record.
