CVE-2024-4350 Concrete CMS version 9 below 9.3.3 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer
A rogue administrator can inject malicious scripts into RSS Displayer fields, leading to stored XSS attacks against other users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-4350?
CVE-2024-4350 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation. The Concrete CMS security team gave this vulnerability a CVSS v4 score of 5.1 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Thanks, m3dium for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)
Weakness: CWE-79
Which versions are affected by CVE-2024-4350?
4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 8.5.18 |
concrete5/concrete5 Packagist | All versions | 8.5.18 |
concrete5/concrete5 Packagist | From 9.0.0RC1 | 9.3.3 |
concrete5/concrete5 Packagist | From 9.0.0RC1 | 9.3.3 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2024-4350?
Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.18 or 9.3.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-4350 being exploited?
There is no known exploitation of CVE-2024-4350 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-q5wx-m95r-4cgc.