{"answers":{"affected":"4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-4350 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.18 or 9.3.3.","what":"CVE-2024-4350 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4350 and fix it if it is affected.\n\nWhat it is: CVE-2024-4350 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-4350 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.18\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.18\n- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.3.3\n- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4350/ (Markdown: https://insights.sbomify.com/CVE-2024-4350/index.md)","id":"CVE-2024-4350","markdown":"https://insights.sbomify.com/CVE-2024-4350/index.md","name":"CVE-2024-4350","record":{"aliases":["GHSA-q5wx-m95r-4cgc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Concrete CMS","requires_auth":"high_privilege","summary":"A rogue administrator can inject malicious scripts into RSS Displayer fields, leading to stored XSS attacks against other users.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"ConcreteCMS","cpe":[{"product":"concrete_cms","vendor":"concretecms"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation. The Concrete CMS security team gave this vulnerability a CVSS v4 score of 5.1 with vector   https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Thanks, m3dium for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Concrete CMS version 9 below 9.3.3 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer","id":"CVE-2024-4350","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"concretecms:concrete_cms","products":["concretecms:concrete_cms"],"type":"xss","year":"2024"},"n_packages":4,"n_references":4,"next":{"headline":"Tutor LMS Pro \u003c= 2.7.0 - Missing Authorization to Privilege Escalation","id":"CVE-2024-4351"},"packages":[{"ecosystem":"Packagist","fixed":["8.5.18"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-q5wx-m95r-4cgc"},{"ecosystem":"Packagist","fixed":["8.5.18"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-q5wx-m95r-4cgc"},{"ecosystem":"Packagist","fixed":["9.3.3"],"introduced":["9.0.0RC1"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-q5wx-m95r-4cgc"},{"ecosystem":"Packagist","fixed":["9.3.3"],"introduced":["9.0.0RC1"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-q5wx-m95r-4cgc"}],"prev":{"headline":"SourceCodester Pisay Online E-Learning System controller.php unrestricted upload","id":"CVE-2024-4349"},"products":["Concrete CMS"],"published":"2024-08-09","related":[{"cvss_score":9.8,"headline":"Concrete CMS allows unauthorized access because directories can be created with insecure permissions","id":"CVE-2023-48648","kev_date_added":null,"published":"2023-11-17"},{"cvss_score":9.8,"headline":"Code injection in concrete CMS","id":"CVE-2022-21829","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.8,"headline":"Server-Side Request Forgery vulnerability in concrete5","id":"CVE-2021-22958","kev_date_added":null,"published":"2021-10-07"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-40098","kev_date_added":null,"published":"2021-09-27"},{"cvss_score":9.4,"headline":"Concrete CMS Vulnerable to Relative Path Traversal","id":"CVE-2026-8134","kev_date_added":null,"published":"2026-05-21"},{"cvss_score":9.1,"headline":"Path traversal in Concrete CMS","id":"CVE-2022-30117","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2021-40102","kev_date_added":null,"published":"2021-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-25","vendors":["Concrete CMS"]},"summary":"A rogue administrator can inject malicious scripts into RSS Displayer fields, leading to stored XSS attacks against other users.","url":"https://insights.sbomify.com/CVE-2024-4350/"}