# CVE-2024-43591: Azure Command Line Integration (CLI) Elevation of Privilege Vulnerability

> Attackers can exploit a command injection flaw in Azure CLI to escalate privileges on the local system.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 19 Aug 2026
- **Also known as:** BIT-azure-cli-2024-43591, GHSA-c675-7cfx-698p, SUSE-SU-2025:0751-1, UBUNTU-CVE-2024-43591

## What is CVE-2024-43591?

CVE-2024-43591 is a high-severity command injection vulnerability in Microsoft Azure CLI, published on 8 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Azure Command Line Integration (CLI) Elevation of Privilege Vulnerability

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-43591?

1 open source package ship an affected version, including azure-cli. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `azure-cli` | Bitnami | All versions | 2.65.0 |
| `azure-cli` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 2.58.0-150400.14.12.1 |
| `azure-cli` | SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 2.58.0-150400.14.12.1 |
| `azure-cli` | SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 2.58.0-150400.14.12.1 |
| `azure-cli-test` | SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 2.58.0-150400.14.12.1 |
| `azure-cli` | openSUSE:Leap 15.6 | All versions | 2.58.0-150400.14.12.1 |
| `azure-cli-test` | openSUSE:Leap 15.6 | All versions | 2.58.0-150400.14.12.1 |

Products: Microsoft Azure Command-Line Interface, Microsoft Azure Service Connector.

## How do I fix CVE-2024-43591?

Upgrade azure-cli to 2.65.0 or later.

## Is CVE-2024-43591 being exploited?

There is no known exploitation of CVE-2024-43591 in the wild and no public exploit code.

## Other vulnerabilities in Microsoft Azure CLI

- [CVE-2023-36052](https://insights.sbomify.com/CVE-2023-36052/): Azure CLI REST Command Information Disclosure Vulnerability (high 8.6)
- [CVE-2025-24049](https://insights.sbomify.com/CVE-2025-24049/): Azure Command Line Integration (CLI) Elevation of Privilege Vulnerability (high 8.4)
- [CVE-2022-39327](https://insights.sbomify.com/CVE-2022-39327/): Improper Control of Generation of Code ('Code Injection') in Azure CLI (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43591 and fix it if it is affected.

What it is: CVE-2024-43591 is a high-severity command injection vulnerability in Microsoft Azure CLI, published on 8 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43591 in the wild and no public exploit code.

Affected packages and fixed versions:
- azure-cli (Bitnami): affected all versions; fixed in 2.65.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43591/ (Markdown: https://insights.sbomify.com/CVE-2024-43591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43591
- OSV: https://osv.dev/vulnerability/CVE-2024-43591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43591/
Summaries are generated and may contain mistakes; the official description above is the record.
