# CVE-2024-43710: Kibana server-side request forgery

> Attackers with Fleet read access can exploit an SSRF vulnerability in Kibana to send requests to internal HTTPS endpoints returning JSON.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2025
- **Updated:** 23 Jan 2025
- **Also known as:** BIT-elk-2024-43710, BIT-kibana-2024-43710, GHSA-5vxg-7wx9-4fp4

## What is CVE-2024-43710?

CVE-2024-43710 is a medium-severity server-side request forgery vulnerability in Elastic Kibana, published on 23 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server side request forgery vulnerability was identified in Kibana where the /api/fleet/health_check API could be used to send requests to internal endpoints. Due to the nature of the underlying request, only endpoints available over https that return JSON could be accessed. This can be carried out by users with read access to Fleet.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-43710?

2 open source packages ship an affected version, including kibana and elk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kibana` | Bitnami | From 8.7.0 | 8.15.0 |
| `elk` | Bitnami | From 8.7.0 | 8.15.0 |

Products: Elastic Kibana.

## How do I fix CVE-2024-43710?

Upgrade kibana to 8.15.0 or later.

## Is CVE-2024-43710 being exploited?

There is no known exploitation of CVE-2024-43710 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Kibana

- [CVE-2019-7609](https://insights.sbomify.com/CVE-2019-7609/): Kibana Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2025-25015](https://insights.sbomify.com/CVE-2025-25015/): Kibana arbitrary code execution via prototype pollution (critical 9.9)
- [CVE-2024-37288](https://insights.sbomify.com/CVE-2024-37288/): Deserialization in Kibana (critical 9.9)
- [CVE-2023-31415](https://insights.sbomify.com/CVE-2023-31415/): Code injection in Kibana (critical 9.9)
- [CVE-2018-17245](https://insights.sbomify.com/CVE-2018-17245/): Information disclosure in Kibana (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43710 and fix it if it is affected.

What it is: CVE-2024-43710 is a medium-severity server-side request forgery vulnerability in Elastic Kibana, published on 23 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43710 in the wild and no public exploit code.

Affected packages and fixed versions:
- kibana (Bitnami): affected from 8.7.0; fixed in 8.15.0
- elk (Bitnami): affected from 8.7.0; fixed in 8.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43710/ (Markdown: https://insights.sbomify.com/CVE-2024-43710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43710
- OSV: https://osv.dev/vulnerability/CVE-2024-43710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43710/
Summaries are generated and may contain mistakes; the official description above is the record.
