CVE-2024-43783 Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies
Attackers can cause denial of service by sending large requests to Apollo Router when specific non-default coprocessor or plugin configurations are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-43783?
CVE-2024-43783 is a high-severity denial of service vulnerability in apollographql router, published on 27 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Apollo Router Core is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Instances of the Apollo Router running versions >=1.21.0 and < 1.52.1 are impacted by a denial of service vulnerability if _all_ of the following are true: 1. The Apollo Router has been configured to support [External Coprocessing](https://www.apollographql.com/docs/router/customizations/coprocessor). 2. The Apollo Router has been configured to send request bodies to coprocessors. This is a non-default configuration and must be configured intentionally by administrators. Instances of the Apollo Router running versions >=1.7.0 and <1.52.1 are impacted by a denial-of-service vulnerability if all of the following are true: 1. Router has been configured to use a custom-developed Native Rust Plugin. 2. The plugin accesses Request.router_request in the RouterService layer. 3. You are accumulating the body from Request.router_request into memory. If using an impacted configuration, the Router will load entire HTTP request bodies into memory without respect to other HTTP request size-limiting configurations like limits.http_max_request_bytes. This can cause the Router to be out-of-memory (OOM) terminated if a sufficiently large request is sent to the Router. By default, the Router sets limits.http_max_request_bytes to 2 MB. If you have an impacted configuration as defined above, please upgrade to at least Apollo Router 1.52.1. If you cannot upgrade, you can mitigate the denial-of-service opportunity impacting External Coprocessors by setting the coprocessor.router.request.body configuration option to false. Please note that changing this configuration option will change the information sent to any coprocessors you have configured and may impact functionality implemented by those coprocessors. If you have developed a Native Rust Plugin and cannot upgrade, you can update your plugin to either not accumulate the request body or enforce a maximum body size limit. You can also mitigate this issue by limiting HTTP body payload sizes prior to the Router (e.g., in a proxy or web application firewall appliance).
Weakness: CWE-770
Which versions are affected by CVE-2024-43783?
2 open source packages ship an affected version, including apollo-router. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
apollo-router crates.io | From 1.7.0 | 1.52.1 |
apollo-router crates.io | From 1.7.0 | 1.52.1 |
Products include Apollographql Apollo-Router, Apollographql Apollo Helms-Charts Router, Apollographql Apollo Router.
How do I fix CVE-2024-43783?
Upgrade apollo-router to 1.52.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-43783 being exploited?
There is no known exploitation of CVE-2024-43783 in the wild and no public exploit code.
Other vulnerabilities in apollographql router
Sources
Also known as GHSA-x6xq-whh3-gg32.