{"answers":{"affected":"2 open source packages ship an affected version, including apollo-router. It affects 3 products.","exploited":"There is no known exploitation of CVE-2024-43783 in the wild and no public exploit code.","fix":"Upgrade apollo-router to 1.52.1 or later.","what":"CVE-2024-43783 is a high-severity denial of service vulnerability in apollographql router, published on 27 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-43783 and fix it if it is affected.\n\nWhat it is: CVE-2024-43783 is a high-severity denial of service vulnerability in apollographql router, published on 27 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-43783 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apollo-router (crates.io): affected from 1.7.0; fixed in 1.52.1\n- apollo-router (crates.io): affected from 1.7.0; fixed in 1.52.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43783/ (Markdown: https://insights.sbomify.com/CVE-2024-43783/index.md)","id":"CVE-2024-43783","markdown":"https://insights.sbomify.com/CVE-2024-43783/index.md","name":"CVE-2024-43783","record":{"aliases":["GHSA-x6xq-whh3-gg32"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apollo Router","requires_auth":"none","summary":"Attackers can cause denial of service by sending large requests to Apollo Router when specific non-default coprocessor or plugin configurations are enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apollo-router","vendor":"apollographql"},{"product":"apollo_helms-charts_router","vendor":"apollographql"},{"product":"apollo_router","vendor":"apollographql"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"The Apollo Router Core is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Instances of the Apollo Router running versions \u003e=1.21.0 and \u003c 1.52.1 are impacted by a denial of service vulnerability if _all_ of the following are true: 1. The Apollo Router has been configured to support [External Coprocessing](https://www.apollographql.com/docs/router/customizations/coprocessor). 2. The Apollo Router has been configured to send request bodies to coprocessors. This is a non-default configuration and must be configured intentionally by administrators. Instances of the Apollo Router running versions \u003e=1.7.0 and \u003c1.52.1 are impacted by a denial-of-service vulnerability if all of the following are true: 1. Router has been configured to use a custom-developed Native Rust Plugin. 2. The plugin accesses Request.router_request in the RouterService layer. 3. You are accumulating the body from Request.router_request into memory. If using an impacted configuration, the Router will load entire HTTP request bodies into memory without respect to other HTTP request size-limiting configurations like limits.http_max_request_bytes. This can cause the Router to be out-of-memory (OOM) terminated if a sufficiently large request is sent to the Router. By default, the Router sets limits.http_max_request_bytes to 2 MB. If you have an impacted configuration as defined above, please upgrade to at least Apollo Router 1.52.1. If you cannot upgrade, you can mitigate the denial-of-service opportunity impacting External Coprocessors by setting the coprocessor.router.request.body configuration option to false. Please note that changing this configuration option will change the information sent to any coprocessors you have configured and may impact functionality implemented by those coprocessors. If you have developed a Native Rust Plugin and cannot upgrade, you can update your plugin to either not accumulate the request body or enforce a maximum body size limit. You can also mitigate this issue by limiting HTTP body payload sizes prior to the Router (e.g., in a proxy or web application firewall appliance).","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies","id":"CVE-2024-43783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":6,"next":{"headline":"Re-creating a deleted user in lakeFS will re-enable previous user credentials that existed prior to it's deletion","id":"CVE-2024-43784"},"packages":[{"ecosystem":"crates.io","fixed":["1.52.1"],"introduced":["1.7.0"],"last_affected":[],"package":"apollo-router","purl":null,"source":"GHSA-x6xq-whh3-gg32"},{"ecosystem":"crates.io","fixed":["1.52.1"],"introduced":["1.7.0"],"last_affected":[],"package":"apollo-router","purl":"pkg:cargo/apollo-router","source":"GHSA-x6xq-whh3-gg32"}],"prev":{"headline":"openedx-translations's Atlas translations for Open edX missing validation","id":"CVE-2024-43782"},"products":["router"],"published":"2024-08-27","related":[{"cvss_score":7.5,"headline":"Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries","id":"CVE-2024-43414","kev_date_added":null,"published":"2024-08-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-27","vendors":["apollographql"]},"summary":"Attackers can cause denial of service by sending large requests to Apollo Router when specific non-default coprocessor or plugin configurations are enabled.","url":"https://insights.sbomify.com/CVE-2024-43783/"}