# CVE-2024-43789: Denial of service by the absence of restrictions on replies to posts in Discourse

> Attackers can cause denial of service by creating posts with excessive replies and fetching them, impacting Discourse instance availability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2024
- **Updated:** 8 Oct 2024
- **Also known as:** BIT-discourse-2024-43789, GHSA-62cq-cpmc-hvqq

## What is CVE-2024-43789?

CVE-2024-43789 is a high-severity denial of service vulnerability in Discourse Discourse, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. A user can create a post with many replies, and then attempt to fetch them all at once. This can potentially reduce the availability of a Discourse instance. This problem has been patched in the latest version of Discourse. All users area are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-43789?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.3.1 |

Products: Discourse Discourse.

## How do I fix CVE-2024-43789?

Upgrade discourse to 3.3.1 or later.

## Is CVE-2024-43789 being exploited?

There is no known exploitation of CVE-2024-43789 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43789 and fix it if it is affected.

What it is: CVE-2024-43789 is a high-severity denial of service vulnerability in Discourse Discourse, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-43789 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43789/ (Markdown: https://insights.sbomify.com/CVE-2024-43789/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43789
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43789
- OSV: https://osv.dev/vulnerability/CVE-2024-43789

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43789/
Summaries are generated and may contain mistakes; the official description above is the record.
