{"answers":{"affected":"2 open source packages ship an affected version, including request_store. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-43791 in the wild and no public exploit code.","fix":"Upgrade request_store to 1.4.0 or later.","what":"CVE-2024-43791 is a high-severity vulnerability in steveklabnik request_store, published on 23 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-43791 and fix it if it is affected.\n\nWhat it is: CVE-2024-43791 is a high-severity vulnerability in steveklabnik request_store, published on 23 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-43791 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- request_store (RubyGems): affected from 1.3.2; fixed in 1.4.0\n- request_store (RubyGems): affected from 1.3.2; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43791/ (Markdown: https://insights.sbomify.com/CVE-2024-43791/index.md)","id":"CVE-2024-43791","markdown":"https://insights.sbomify.com/CVE-2024-43791/index.md","name":"CVE-2024-43791","record":{"aliases":["GHSA-frp2-5qfc-7r8m","UBUNTU-CVE-2024-43791"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby Rack library","requires_auth":"low_privilege","summary":"Local attackers can execute arbitrary code due to world-writable file permissions in the RequestStore Ruby library.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"request_store","vendor":"steveklabnik"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"RequestStore provides per-request global storage for Rack. The files published as part of request_store 1.3.2 have 0666 permissions, meaning that they are world-writable, which allows local users to execute arbitrary code. This version was published in 2017, and most production environments do not allow access for local users, so the chances of this being exploited are very low, given that the vast majority of users will have upgraded, and those that have not, if any, are not likely to be exposed.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RequestStore has Incorrect Default Permissions","id":"CVE-2024-43791","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"misconfiguration","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Halo's editor has a stored Cross-Site Scripting vulnerability","id":"CVE-2024-43792"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["1.3.2"],"last_affected":[],"package":"request_store","purl":null,"source":"GHSA-frp2-5qfc-7r8m"},{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["1.3.2"],"last_affected":[],"package":"request_store","purl":"pkg:gem/request_store","source":"GHSA-frp2-5qfc-7r8m"}],"prev":{"headline":"heap-buffer-overflow in do_search() in Vim \u003c 9.1.0689","id":"CVE-2024-43790"},"products":["request_store"],"published":"2024-08-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-23","vendors":["steveklabnik"]},"summary":"Local attackers can execute arbitrary code due to world-writable file permissions in the RequestStore Ruby library.","url":"https://insights.sbomify.com/CVE-2024-43791/"}