# CVE-2024-43795: OpenC3 COSMOS vulnerable to cross-site scripting in Login functionality (`GHSL-2024-128`)

> Attackers can execute arbitrary scripts in users' browsers via the login page, potentially leading to session hijacking or data theft.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2024
- **Updated:** 31 Oct 2024
- **Also known as:** GHSA-vfj8-5pj7-2f9g, PYSEC-2024-100

## What is CVE-2024-43795?

CVE-2024-43795 is a medium-severity cross-site scripting vulnerability in OpenC3 cosmos, published on 2 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. The login functionality contains a reflected cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 5.19.0. Note: This CVE only affects Open Source Edition, and not OpenC3 COSMOS Enterprise Edition.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-43795?

7 open source packages ship an affected version, including openc3 and @openc3/tool-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openc3` | PyPI | All versions | 5.19.0 |
| `openc3` | PyPI | All versions | 5.19.0 |
| `openc3` | PyPI | All versions | 5.19.0 |
| `openc3` | RubyGems | All versions | 5.19.0 |
| `openc3` | RubyGems | All versions | 5.19.0 |
| `@openc3/tool-common` | npm | All versions | 5.19.0 |
| `@openc3/tool-common` | npm | All versions | 5.19.0 |

Products: Openc3 Cosmos.

## How do I fix CVE-2024-43795?

Upgrade openc3 to 5.19.0 or later.

## Is CVE-2024-43795 being exploited?

There is no known exploitation of CVE-2024-43795 in the wild and no public exploit code.

## Other vulnerabilities in OpenC3 cosmos

- [CVE-2025-28386](https://insights.sbomify.com/CVE-2025-28386/): Code injection in n/a (critical 9.8)
- [CVE-2025-28388](https://insights.sbomify.com/CVE-2025-28388/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2025-28389](https://insights.sbomify.com/CVE-2025-28389/): Weak cryptography in n/a (critical 9.8)
- [CVE-2026-42087](https://insights.sbomify.com/CVE-2026-42087/): OpenC3 COSMOS: SQL Injection in QuestDB Time-Series Data Base (critical 9.6)
- [CVE-2026-42088](https://insights.sbomify.com/CVE-2026-42088/): OpenC3 COSMOS: Administrative Actions via the Script Runner Tool (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43795 and fix it if it is affected.

What it is: CVE-2024-43795 is a medium-severity cross-site scripting vulnerability in OpenC3 cosmos, published on 2 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-43795 in the wild and no public exploit code.

Affected packages and fixed versions:
- openc3 (PyPI): affected all versions; fixed in 5.19.0
- openc3 (PyPI): affected all versions; fixed in 5.19.0
- openc3 (PyPI): affected all versions; fixed in 5.19.0
- openc3 (RubyGems): affected all versions; fixed in 5.19.0
- openc3 (RubyGems): affected all versions; fixed in 5.19.0
- @openc3/tool-common (npm): affected all versions; fixed in 5.19.0
- @openc3/tool-common (npm): affected all versions; fixed in 5.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43795/ (Markdown: https://insights.sbomify.com/CVE-2024-43795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43795
- OSV: https://osv.dev/vulnerability/CVE-2024-43795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43795/
Summaries are generated and may contain mistakes; the official description above is the record.
