CVE-2024-43796 express vulnerable to XSS via response.redirect()

Medium 5.0 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-43796?

CVE-2024-43796 is a medium-severity vulnerability in expressjs express, published on 10 Sep 2024.

Official description

Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

Weakness: CWE-79

Which versions are affected by CVE-2024-43796?

4 open source packages ship an affected version, including express. It affects 1 product.

PackageAffectedFixed in
express npmAll versions4.20.0
express npmAll versions4.20.0
express npmFrom 5.0.0-alpha.15.0.0
express npmFrom 5.0.0-alpha.15.0.0

Products include Openjsf Express.

How do I fix CVE-2024-43796?

Upgrade express to a fixed version for your release line: 4.20.0 or 5.0.0.

Is CVE-2024-43796 being exploited?

There is no known exploitation of CVE-2024-43796 in the wild and no public exploit code.

Sources

Also known as AZL-49053, AZL-49091, AZL-49135, AZL-49152, CLSA-2026-1781484857, CLSA-2026-1792491907 and 5 more.

Is CVE-2024-43796 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free