{"answers":{"affected":"2 open source packages ship an affected version, including send. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-43799 in the wild and no public exploit code.","fix":"Upgrade send to 0.19.0 or later.","what":"CVE-2024-43799 is a medium-severity cross-site scripting vulnerability in pillarjs send, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-43799 and fix it if it is affected.\n\nWhat it is: CVE-2024-43799 is a medium-severity cross-site scripting vulnerability in pillarjs send, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-43799 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- send (npm): affected all versions; fixed in 0.19.0\n- send (npm): affected all versions; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-43799/ (Markdown: https://insights.sbomify.com/CVE-2024-43799/index.md)","id":"CVE-2024-43799","markdown":"https://insights.sbomify.com/CVE-2024-43799/index.md","name":"CVE-2024-43799","record":{"aliases":["AZL-49088","AZL-49123","AZL-49164","CLSA-2026-1791841547","CLSA-2026-1791850713","CLSA-2026-1792477991","CLSA-2026-1792490955","CLSA-2026-1793098701","CLSA-2026-1793291196","DEBIAN-CVE-2024-43799","DLA-4224-1","GHSA-m6fv-jmcg-4jfg","MINI-2r9m-x85w-fwcf","MINI-35px-vjr3-29x3","ROOT-APP-NPM-CVE-2024-43799","UBUNTU-CVE-2024-43799"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js file streaming library","requires_auth":"none","summary":"Attackers can inject malicious scripts via untrusted input in the send library, leading to XSS and potential code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"send","vendor":"send_project"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Send is a library for streaming files from the file system as a http response. Send passes untrusted user input to SendStream.redirect() which executes untrusted code. This issue is patched in send 0.19.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"send vulnerable to template injection that can lead to XSS","id":"CVE-2024-43799","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"serve-static affected by template injection that can lead to XSS","id":"CVE-2024-43800"},"packages":[{"ecosystem":"npm","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"send","purl":null,"source":"GHSA-m6fv-jmcg-4jfg"},{"ecosystem":"npm","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"send","purl":"pkg:npm/send","source":"GHSA-m6fv-jmcg-4jfg"}],"prev":{"headline":"Chisel AUTH environment variable not respected in server entrypoint","id":"CVE-2024-43798"},"products":["send"],"published":"2024-09-10","related":[{"cvss_score":5.3,"headline":"Root Path Disclosure in send","id":"CVE-2015-8859","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["pillarjs"]},"summary":"Attackers can inject malicious scripts via untrusted input in the send library, leading to XSS and potential code execution.","url":"https://insights.sbomify.com/CVE-2024-43799/"}