# CVE-2024-43799: send vulnerable to template injection that can lead to XSS

> Attackers can inject malicious scripts via untrusted input in the send library, leading to XSS and potential code execution.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Sep 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-49088, AZL-49123, AZL-49164, CLSA-2026-1791841547, CLSA-2026-1791850713, CLSA-2026-1792477991, CLSA-2026-1792490955, CLSA-2026-1793098701, CLSA-2026-1793291196, DEBIAN-CVE-2024-43799, DLA-4224-1, GHSA-m6fv-jmcg-4jfg, MINI-2r9m-x85w-fwcf, MINI-35px-vjr3-29x3, ROOT-APP-NPM-CVE-2024-43799, UBUNTU-CVE-2024-43799

## What is CVE-2024-43799?

CVE-2024-43799 is a medium-severity cross-site scripting vulnerability in pillarjs send, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Send is a library for streaming files from the file system as a http response. Send passes untrusted user input to SendStream.redirect() which executes untrusted code. This issue is patched in send 0.19.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-43799?

2 open source packages ship an affected version, including send. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `send` | npm | All versions | 0.19.0 |
| `send` | npm | All versions | 0.19.0 |

Products: Send Project Send.

## How do I fix CVE-2024-43799?

Upgrade send to 0.19.0 or later.

## Is CVE-2024-43799 being exploited?

There is no known exploitation of CVE-2024-43799 in the wild and no public exploit code.

## Other vulnerabilities in pillarjs send

- [CVE-2015-8859](https://insights.sbomify.com/CVE-2015-8859/): Root Path Disclosure in send (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43799 and fix it if it is affected.

What it is: CVE-2024-43799 is a medium-severity cross-site scripting vulnerability in pillarjs send, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-43799 in the wild and no public exploit code.

Affected packages and fixed versions:
- send (npm): affected all versions; fixed in 0.19.0
- send (npm): affected all versions; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43799/ (Markdown: https://insights.sbomify.com/CVE-2024-43799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43799
- OSV: https://osv.dev/vulnerability/CVE-2024-43799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43799/
Summaries are generated and may contain mistakes; the official description above is the record.
