# CVE-2024-43802: heap-buffer-overflow in ins_typebuf() in Vim < 9.1.0697

> A heap-buffer overflow in Vim's typeahead buffer handling can cause a crash when specific error conditions and mappings are active.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2024
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2024-43802, AZL-48221, AZL-48282, BELL-CVE-2024-43802, CLSA-2024-1729193618, DEBIAN-CVE-2024-43802, GHSA-4ghr-c62x-cqfh, OESA-2024-2115, UBUNTU-CVE-2024-43802, USN-7048-1, USN-7048-2

## What is CVE-2024-43802?

CVE-2024-43802 is a medium-severity memory corruption vulnerability in vim, published on 26 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Vim is an improved version of the unix vi text editor. When flushing the typeahead buffer, Vim moves the current position in the typeahead buffer but does not check whether there is enough space left in the buffer to handle the next characters.  So this may lead to the tb_off position within the typebuf variable to point outside of the valid buffer size, which can then later lead to a heap-buffer overflow in e.g. ins_typebuf(). Therefore, when flushing the typeahead buffer, check if there is enough space left before advancing the off position. If not, fall back to flush current typebuf contents. It's not quite clear yet, what can lead to this situation. It seems to happen when error messages occur (which will cause Vim to flush the typeahead buffer) in comnination with several long mappgins and so it may eventually move the off position out of a valid buffer size. Impact is low since it is not easily reproducible and requires to have several mappings active and run into some error condition. But when this happens, this will cause a crash. The issue has been fixed as of Vim patch v9.1.0697. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-43802?


## How do I fix CVE-2024-43802?

Upgrade to a fixed version.

## Is CVE-2024-43802 being exploited?

There is no known exploitation of CVE-2024-43802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43802 and fix it if it is affected.

What it is: CVE-2024-43802 is a medium-severity memory corruption vulnerability in vim, published on 26 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-43802 in the wild and no public exploit code.

Affected product: vim. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43802/ (Markdown: https://insights.sbomify.com/CVE-2024-43802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43802
- OSV: https://osv.dev/vulnerability/CVE-2024-43802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43802/
Summaries are generated and may contain mistakes; the official description above is the record.
