# CVE-2024-43917: WordPress TI WooCommerce Wishlist plugin <= 2.8.2 - SQL Injection vulnerability

> Attackers can execute arbitrary SQL commands via the TI WooCommerce Wishlist plugin, potentially reading or modifying database contents.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Aug 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-cfvh-qp4v-2hqc

## What is CVE-2024-43917?

CVE-2024-43917 is a critical SQL injection vulnerability in TemplateInvaders TI WooCommerce Wishlist, published on 29 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in TemplateInvaders TI WooCommerce Wishlist allows SQL Injection.This issue affects TI WooCommerce Wishlist: from n/a through 2.8.2.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-43917?

It affects 1 product.


Products: Templateinvaders Ti Woocommerce Wishlist.

## How do I fix CVE-2024-43917?

No fix has been published for CVE-2024-43917 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-43917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43917 exists.

Public exploit code:

- https://github.com/p33d/CVE-2024-43917 (github_poc): https://github.com/p33d/CVE-2024-43917
- WordPress TI WooCommerce Wishlist SQL Injection (CVE-2024-43917) (metasploit)
- TI WooCommerce Wishlist (WordPress plugin) <= 2.8.2 CVE-2024-43917 PoC (github_poc): https://github.com/sug4r-wr41th/CVE-2024-43917
- WordPress TI WooCommerce Wishlist Plugin <= 2.8.2 - SQL Injection (nuclei): http/cves/2024/CVE-2024-43917.yaml

## Other vulnerabilities in TemplateInvaders TI WooCommerce Wishlist

- [CVE-2022-0412](https://insights.sbomify.com/CVE-2022-0412/): TI WooCommerce Wishlist < 1.40.1 - Unauthenticated Blind SQL Injection (critical 9.8)
- [CVE-2020-36725](https://insights.sbomify.com/CVE-2020-36725/): TI WooCommerce Wishlist <= 1.21.11 and TI WooCommerce Wishlist Pro <= 1.21.4 - Arbitrary Options Update (high 8.8)
- [CVE-2024-9156](https://insights.sbomify.com/CVE-2024-9156/): TI WooCommerce Wishlist <= 2.8.2 - Unauthenticated SQL Injection via lang parameters (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-43917 and fix it if it is affected.

What it is: CVE-2024-43917 is a critical SQL injection vulnerability in TemplateInvaders TI WooCommerce Wishlist, published on 29 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-43917 exists.

Affected product: TemplateInvaders TI WooCommerce Wishlist. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-43917/ (Markdown: https://insights.sbomify.com/CVE-2024-43917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-43917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-43917
- OSV: https://osv.dev/vulnerability/CVE-2024-43917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-43917/
Summaries are generated and may contain mistakes; the official description above is the record.
