CVE-2024-44073 Miniscript allows stack consumption

High 7.5 Published Updated

Attackers can cause stack exhaustion and denial of service in applications using the Miniscript library by exploiting improper tree depth tracking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-44073?

CVE-2024-44073 is a high-severity denial of service vulnerability in n/a, published on 19 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Miniscript (aka rust-miniscript) library before 12.2.0 for Rust allows stack consumption because it does not properly track tree depth.

Weakness: CWE-787, CWE-674

Which versions are affected by CVE-2024-44073?

8 open source packages ship an affected version, including miniscript. It affects 1 product.

PackageAffectedFixed in
miniscript crates.ioAll versions9.2.0
miniscript crates.ioAll versions9.2.0
miniscript crates.ioFrom 10.0.010.2.0
miniscript crates.ioFrom 10.0.010.2.0
miniscript crates.ioFrom 11.0.011.2.0
miniscript crates.ioFrom 11.0.011.2.0
2 more packages
miniscript crates.ioFrom 12.0.012.2.0
miniscript crates.ioFrom 12.0.012.2.0

Products include Rust-Bitcoin Miniscript.

How do I fix CVE-2024-44073?

Upgrade miniscript to a fixed version for your release line: 9.2.0, 10.2.0, 11.2.0 or 12.2.0.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-44073 being exploited?

There is no known exploitation of CVE-2024-44073 in the wild and no public exploit code.

Sources

Also known as GHSA-rv9v-r4vm-gj8x.

Is CVE-2024-44073 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free