{"answers":{"affected":"8 open source packages ship an affected version, including miniscript. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-44073 in the wild and no public exploit code.","fix":"Upgrade miniscript to a fixed version for your release line: 9.2.0, 10.2.0, 11.2.0 or 12.2.0.","what":"CVE-2024-44073 is a high-severity denial of service vulnerability in n/a, published on 19 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-44073 and fix it if it is affected.\n\nWhat it is: CVE-2024-44073 is a high-severity denial of service vulnerability in n/a, published on 19 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-44073 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- miniscript (crates.io): affected all versions; fixed in 9.2.0\n- miniscript (crates.io): affected all versions; fixed in 9.2.0\n- miniscript (crates.io): affected from 10.0.0; fixed in 10.2.0\n- miniscript (crates.io): affected from 10.0.0; fixed in 10.2.0\n- miniscript (crates.io): affected from 11.0.0; fixed in 11.2.0\n- miniscript (crates.io): affected from 11.0.0; fixed in 11.2.0\n- miniscript (crates.io): affected from 12.0.0; fixed in 12.2.0\n- miniscript (crates.io): affected from 12.0.0; fixed in 12.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-44073/ (Markdown: https://insights.sbomify.com/CVE-2024-44073/index.md)","id":"CVE-2024-44073","markdown":"https://insights.sbomify.com/CVE-2024-44073/index.md","name":"CVE-2024-44073","record":{"aliases":["GHSA-rv9v-r4vm-gj8x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust Miniscript library","requires_auth":"none","summary":"Attackers can cause stack exhaustion and denial of service in applications using the Miniscript library by exploiting improper tree depth tracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"miniscript","vendor":"rust-bitcoin"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"The Miniscript (aka rust-miniscript) library before 12.2.0 for Rust allows stack consumption because it does not properly track tree depth.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Miniscript allows stack consumption","id":"CVE-2024-44073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":8,"n_references":3,"next":{"headline":"Microcks's POST /api/import and POST /api/export endpoints allow non-administrator access","id":"CVE-2024-44076"},"packages":[{"ecosystem":"crates.io","fixed":["9.2.0"],"introduced":["0"],"last_affected":[],"package":"miniscript","purl":null,"source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["9.2.0"],"introduced":["0"],"last_affected":[],"package":"miniscript","purl":"pkg:cargo/miniscript","source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["10.2.0"],"introduced":["10.0.0"],"last_affected":[],"package":"miniscript","purl":null,"source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["10.2.0"],"introduced":["10.0.0"],"last_affected":[],"package":"miniscript","purl":"pkg:cargo/miniscript","source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["11.2.0"],"introduced":["11.0.0"],"last_affected":[],"package":"miniscript","purl":null,"source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["11.2.0"],"introduced":["11.0.0"],"last_affected":[],"package":"miniscript","purl":"pkg:cargo/miniscript","source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["12.2.0"],"introduced":["12.0.0"],"last_affected":[],"package":"miniscript","purl":null,"source":"GHSA-rv9v-r4vm-gj8x"},{"ecosystem":"crates.io","fixed":["12.2.0"],"introduced":["12.0.0"],"last_affected":[],"package":"miniscript","purl":"pkg:cargo/miniscript","source":"GHSA-rv9v-r4vm-gj8x"}],"prev":{"headline":"Command injection in WEX-1166DHP","id":"CVE-2024-44072"},"products":["n/a"],"published":"2024-08-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-13","vendors":["n/a"]},"summary":"Attackers can cause stack exhaustion and denial of service in applications using the Miniscript library by exploiting improper tree depth tracking.","url":"https://insights.sbomify.com/CVE-2024-44073/"}